SculptMesh problems (repost)


I am trying to use the Sculpt Mesh ( script, but it doesn’t seem to be happening for me. I tried both the 23 and the 25 versions, also in both blender 2.37 and 2.4, and I’ve got both Python 2.3 and 2.4 installed, and both my Blenders are finding them fine.

When I run the script in 3.7, I get no complaints, but LMB on the object doesn’t change anything, simply alters the shading of the object for the time the button is held down and the word “cube” in the lower lefthand corner changes to “mesh” and back. Using scupt mesh 25 in blender 2.4 gives me the following runtime error when I click LMB.

Traceback (most recent call last):
File “<string>”, line 852, in ?
File “<string>”, line 776, in main
File “<string>”, line 387, in displace_vertices
RuntimeError: uv list is empty

Any suggestions as to what I may be missing or any possible workarounds would be appreciated. I actually do use a Wacom tablet, so I also downloaded PyTablet, which doesn’t seem to be causing any problems… But the behavior of the script is the same with or without PyTablet installed.



Hi Tony,

try the version I posted in the thread

You will have to copy and paste it right now… (hopefully I will be able to get a zip posted, but right now the wiki doesn’t allow it).

However with just a cube it doesn’t work - you need to subdivide it a bit more…


I can email you the 29 version if you like… just pm or email me.