Seams issues

Hey Guys,
I am facing this problem, I have searched in the forum and couldnt able to find a solution for this, I think I am doing something wrong here, I want to bake a high res mesh into a lowres mesh as normal map
I have tired baking it and it is working but I am getting wierd gradient when i apply the map on the low res.
The maps seems to be fine but for some reason when I apply it its not working fine,Please see the images below.



Thanks in advance

UPDATE:
I have an idea why this is happening, I tried applying the same map in Houdini, It works fine but in houdini mantra shader we have an option to set the value range to 0 to 1 or -1 to 1 , When I set that to -1 to 1 , I got the same result as I got in blender, So I think If I some how remap the values between 0 to 1 in blender it might work. please someone let me know if im right.

Actually I think you have it backwards, but I could be wrong. When you are getting the error in Houdini by setting it to -1 to 1 that means that the texture is already remapped from 0 to 1.

A few things to check or try in Blender.

Is scene your color space set to Linear or RGB?

This info from the Houdini manual might be helpful:

The values of a normal vector are naturally in the [-1,1] range.

Since negative texture values are difficult to work with and impossible to store in some texture formats, applications usually remap the values to the [0,1] range before they’re stored in a texture.

When rendering with textures stored in this format, leave the Normal Space parameter on mantra shaders at the default of 0 to 1 .

Formats like .rat and .exr can store the normals using their natural [-1,1] range, so you may sometimes encounter textures that are stored this way. In this case set Normal Space to -1 to 1 .

Flipped X & Y

Textures exported from some packages will have the Y , and more rarely the X component flipped. If your texture imports flipped, use the Flip X and Flip Y parameters on mantra shaders to correct it.

Color Space

You should store detail maps in linear color space . If you save a map in an image format that is natively sRGB (such as TIFF, JPEG, or PNG), you must avoid applying gamma to the image.

  • If you write a detail map with the Composite ROP, turn off Convert to Image Format’s Colorspace .
  • If you load a map in a Texture VOP, set the color space to Linear to prevent gamma correction.
  • If you load a map into the compositor with a File COP, turn off Linearize Non-Linear Images .

Also what is the color space setting of the Normal map node?

And what image format did you bake to?

set the color space of the texture to “non color” and bake again