second texture channel not showing correctly

There must be something simple that I’m missing.
I have an object - a large, gray ventilation pipe running diagonal through the pic below. I have a color texture in the first texture channel and a shadow map in the second channel.
In the textured object view, it shows like it should:


In the game engine, however, it’s acting as if I had assigned the texture channel to the wrong UV texture - which I have not. If I had that would be obvious in the textured view.


The settings I have for the UVs and the materials and the textures are exactly the same as all my other objects, and they have come out fine.

So here’s what the problem is not:
-2nd UV texture is correctly mapped to the image
-2nd texture is set to multiply, and the 1st set to default mix
-glsl materials are on
-both texture channels are enabled
-the correct UV texture is selected under “Mapping” for both textures
-the correct image is loaded for both texture channels.
-I deleted both texture channels and made new ones, just to check. Same exact issue. -I deleted the shadow map UV texture, and re-baked the map. Same problem.

Can anyone think of anything else that could be the cause of this glitch?

Update - I should have mentioned that when the shadow texture channel is unchecked, the weird mapping doesn’t show up in the GE. Which leads me to believe that this is an issue of the GE not reading the correct UV texture for the texture image. Is this a glitch? Why only on this object?

Since obviously no one had any idea what I was taking about I had to rely on my Blender-ninja-skills to solve this myself…
Actually the solution was pretty ham-fisted. I appended the offending object to new blend file, thinking I would put in a bug tracker, but found that the texturing problem had solved itself in the new .blend. Now, I’m not crazy, the issue was still occurring in the original .blend. So, I deleted the object in the original, and appended it from the new .blend. Problem solved.

Why? No idea. Some glitch between the game engine and the UV uwrapping-what-cha-ma-call-it?
I wonder if I should still submit a bug tracker - I’m not sure there’s anything to track, unless it happens again.
I guess this was a quirk/glitch of the game engine.