Section - architecture, engines, ect. with Nodes

Hi,

Can I render only the slice of the object?

I had received one answer by Mats, however I doesn’t understand how I solved my problem using render layers.

This ilustrate my problem and what I wanna make.

I attached the blender file used to render the images
—>spheres.blend (193 KB)

I will use this procedure to voxelize mesh models for use in physics applications.

Thanks in advance for any help.

I can help you only with your first problem (you send me as private http://www.flickr.com/photos/[email protected]/ ).

  • for smaller sphere change normals from outside to inside Ctrl+Shift+N
  • copy material of bigger sphere and change color (to red or what ever you want) and setup material as shadeless

(or just (for small sphere) change gray to your “section” green color + shadeless option in your file)

There are other ways how to do it. My offer is just for your post.

The second has no solution for me. Front/Back function has problem correctly analyze what is out / in normal of a mesh from acute angle view (as you can see also in material preview). mzungu did some success experiments with z-offset setup (but I didn’t).
I tried this Front/Back in 2.5 version, but with the same result.
So its ask to coders if they can improve it.

Attachments


spheres-2.blend (192 KB)

Now I tried to download file again and render spheres from several angles. All of them are clear without front/back conflicts.
I used the same (your) file, the same build, the same machine, the same hands . . . and looks OK.

Then I opened file (I downloaded at the first time) and there its still with artefacts as in image posted above.
I’m a bit confused what is going on? Hm

Hard to say something decorous :slight_smile:

3x Spehers animation - download

  • I didnt setup material for small one Its about front/back problems

one note to your first post - isn’t problem that your section render is not from a middle of sphere?

Now, I don’t see the front/back conflicts but now I used orthographic lens to voxelize.

I’m attached two images of a voxelized version of the concentric spheres. ( I saved the render sequence with png, 100%, and I used the ImageJ to open the images of the render).



Your solution give-me a idea, look the result:


I set material “emit” to “1” and put color of the surface like the previous object interior.

This is the blend file:

—>rgb_test.blend (242 KB)

Thank you very much!

ha! :slight_smile: ok the same brain was my problem :slight_smile: I changed orthographic to perspective mode. So you are right front/back function works correctly only in camera ORTHOGRAPHIC mode. its good to know where problems come from :slight_smile: Thanks

and about emit it looks like it works in the same way as shadeless :slight_smile:

good luck

Yep, switching to orthographic solved the high-incidence-angle issue! (I don’t like the look of the animation as well in ortho mode, but for those familiar with looking at 3D CAD models, which normally operate in ortho, the change isn’t that noticable.) Thanks for this tip!

Now the final issue of co-planar faces (from adjacent parts). The z-offset tweak isn’t optimal since it doesn’t support negative values, so editing the meshes will have to do, and just not worrying about minor situations.

wow this is amazing! duh why didn’t I think about it earlier!

finally an easy solution to cut section rendering during render time :wink:

It’s funny Matt, but when I do you tutorial in 2.5 I don’t get the black where the cut is but a gray.
Is there something different in 2.5 that would do that[ATTACH=CONFIG]121760[/ATTACH]?

(solved) ‘Transparency’ is what I missed. Thanks anyway.

Thank you very much!
I’ve been looking for a solution to this problem! This is very important for engineering.

why invert rotate direction of slice by object?


working with cycle?

I just tried your settings around, it’s nice. I added an outline to the section, you can adjust the thickness of the outline with the Dilate/Erode node:


Attachments


I tried a different technique that does not use nodes. Cut out the cross section using a solid object and boolean intersect. Duplicate that object and apply solidify, boolean intersect and another solidify.

Here is a simple example:

Nice to see thread still active :slight_smile:
Thanks for comments.

@RoN43: there wasn’t any revision of node setup since 2.49. So hard to say, many changes from that time. Try to build anew node tree.
@viralata: any feature is welcome :slight_smile:
@atnnn: I was thinking about the same, but hard to imagine use boolean modifier on complex models like engine, house ect.

Just for those interested in cycles version visit http://blenderartists.org/forum/showthread.php?242127.
There is continue of this story. Also a few tests with real storm_st’s Volume Shader so you don’t need to add extra faces to the scene and combine nodes in post process (sadly I can’t find any actual build for blender 2.64)

is there any chance someone could do a full tutorial of this explaining what each part does and so on? im an architecture student trying to do a render of a multi object/ layer model and having the ability to hatch the thicknesses and even make a thicker line around the section would be just fantastic. this is really great stuff here but the problem is that for someone whos not into the more complex blender stuff this is pretty hard to get your head around :frowning: