Seemlessly activate window with multiple monitors

Windows Defender. It’s been a while, so I don’t remember the exact message, but I’ll try downloading it again soon, probably this evening. I’ll also search for any log entries for more detailed info.

OK, just tried a scan with windows defender with no detection…

This is on Windows 10:



I was wrong about my Windows 7 machine: it didn’t detected anything. Don’t know why it did before, unless I mistakenly thought I had switched to the other PC (they use the same screens). Also, Windows 7 uses Microsoft Security Essentials, not Windows Defender (which is the antivirus on Windows 8 & 10). If I understand correctly, Defender operates closer to the OS level than MSE.

Here’s the Microsoft link for the trojan:
https://www.microsoft.com/security/portal/threat/encyclopedia/entry.aspx?name=Trojan%3AWin32%2FFuery.B!cl&threatid=2147718514&enterprise=0

OK, it’s strange, I have windows 7 pro (which have windows defender) and it is not detected, I will try to find if there is a solution…

Are both versions detected ?
I tested the last version on virustotal.com it has not been faultly detected by any antivirus so I don’t know why it is on your computer, but thanks for sharing your details.

It seems to be windows 10 defender problem since I get the quarantine warning too and it will delete the file from my computer unless I add it in “white list” which some casual ppl wont do or know how to do… which is shame since this program helps hell lot of nerves when used blender with multiple monitors.

I hope you find some way around it for other users.

Further developments – and this is really, really strange.

As the following forum entries state, it does appear to be a false positive:
https://ember-online.com/forums/viewtopic.php?f=6&t=638&start=60


Since Kaspersky is one of the best, I tested the second forum entry’s theory by using Microsoft Edge to download the exact same file instead of Chrome. This time there were no warnings, even after I did a user-initiated scan of the zip file afterward.

But here is where it really gets weird: I moved the “good” zip file to another folder, then download the zip file in Chrome again to compare file sizes — but this time it did NOT trigger the anti-virus warning. The file was the exact same size, too. (I wish now I had recorded the size of the previous “bad file” to validate the second forum’s corrupted download theory.) My guess is that once Edge determined it was a safe file, it white-listed it at the OS level, which means that Defender didn’t get in the way of the subsequent Chrome download. (The early versions of MSE have been known to corrupt files.)

In any case, it would be useful if someone else with a Win10 machine tried this method to see if they get the same results as I did. It’s worth it to declare such a useful tool safe to use.

Typical Microsoft! Design operating systems to maximize confusion and time waste. :mad: Definitely thinking of going to another anti-virus if this test is verified.

Just tried on a virtual machine with windows 10, I downloaded with chrome without detection, and when tried to open the zip windows defender alerted me that the editor was unknown asking to not run or run anyway. So I tried with edge and it does the same thing, no detection but the warning…

I believe the warning message you got is a standard for Window’s default User Account level setting. I don’t know why you didn’t get the virus alert. Windows 10 Pro vs Home, maybe? (I have Pro.) Who knows. In any case, thanks for testing this.

fiendish55, since you got the same original virus warning I did, would you mind trying this? Thanks.

Removed windows defender exclusion downloaded newest version with microsoft Edge no virus warnings anymore very odd…

Thank you so much! It works really great!
It would be great if Blender could automatically bring all the windows with the same file opened to front and would not show the subwindows as regular windows. With more than one file opened at a time it is really hard to keep track which window corresponds to which file. But I guess this is out of the scope of this great little utility…

Maybe they updated the virus to get rid of the false positive. It was reported to Microsoft, if that one forum post is to be believed.

greg2fs: Just took the leap and installed it. So far, so good! Thanks!!

I’m happy to know it is no more detected and that it work as expected !
maraCZ, I’m not sure to understand, you have several file opened (so several instances of blender), and you would like the tool to activate the window below the mouse cursor even on the same screen ?

@greg2fs:
Imagine that I open a file X with this setup - 3D window on the left monitor and node editor on the right monitor.
Now I open a file Y with the same multimonitor setup.
Now I want to switch back to the file X. In my taskbar I have four separate icons and it is not easy to remember which window belongs to which opened file.
I bring the 3d window of the file X to front but the node editor of the file X does not come to front automaticaly. It is hidden under the node editor of the file Y. Now it starts to be quite confusing. There is no easy way to find out which icon on the taskbar represents the node editor of the file X.
Node editor of the file X looks almost the same as the node editor of the file Y. I need to concentrate more on bringing the right window to front than on actual work. Now imagine the same situation with more than two opened files.

maraCZ I understand, I had a morning to loose so I added a new version of the tool.
This one also check for several instances of blender, and hide the buttons in double in the taskbar, then when you put a blender window in foreground it put all window of the same instance to foreground. It also close automatically. It can take 1 second to do…
If you open the blender window after launching the tool you’ll have to click the tray icon two times (deactivate and reactivate) for the tool to record the new windows. It could be automatic but I preferred to use the less cpu possible (~0% actually).
Please check and tell me.

Good feature but it has odd problem where the second instance of blender completely lose its minimize, maximize buttons and alter normal top taskbar.

Yes because to hide the button from the task bar I make the window become a tool window which doesn’t support min/max buttons , is it a problem as you can double click to maximise/restore ? And I would add detection for minimized window to minimise all of the same instance ?
One question when you say the “second instance” you mean the “second window of the same as instance” ?
And what do you mean by “normal top taskbar” ? The title bar ?

@greg2fd: Thank you very much for your work on this issue!
I tested your latest version and I experienced the same problem as described by fiendish55. The problem is that if you open two separate files - each with two separate windows the tool joins all four windows into one. It should join the first two windows with file A into one window and the second two windows into second window. This way you can still see two blender icons on taskbar, each representing one opened blender file.
I think it is not necessary to have the maximize and minimize buttons. The problem is that currently it is not possible to switch between the two separate files. It even happened to me that I closed the file A and the file B was still opened but not visible on the taskbar. It was running somewhere in the background (minimized) and I found no way to bring it to front.

With just one file opened it works very well. :slight_smile:

Ok so it is a bug as for me with 2 files opened I have two buttons in the taskbar.
The question is why… Can you tell if you have the name of the file in the title bar (without the tool running) as it’s currently the way it check for the instances ?