Seg Fault issue on my machine

Hello,

Just tried to run Blender 2.82 on Linux 64, all I got was a seg fault and this dump:

Blender 2.82 (sub 7), Commit date: 2020-02-12 16:20, Hash 77d23b0bd76f

backtrace

./blender(BLI_system_backtrace+0x1d) [0x6fbcb2d]
./blender() [0x1657f69]
/lib64/libc.so.6(+0x37ec0) [0x7f71dbf88ec0]
./blender(GPU_draw_list_command_add+0x58) [0x5cc5348]
./blender() [0x195a5f0]
./blender() [0x195ba2f]
./blender(workbench_deferred_draw_scene+0x45a) [0x197944a]
./blender() [0x19757cb]
./blender(DRW_draw_render_loop_ex+0x265) [0x1954df5]
./blender(view3d_main_region_draw+0x77) [0x1f2cc07]
./blender(ED_region_do_draw+0x8f1) [0x1b6a811]
./blender(wm_draw_update+0x496) [0x181db86]
./blender(WM_main+0x30) [0x181bbf0]
./blender(main+0x317) [0x159e5b7]
/lib64/libc.so.6(__libc_start_main+0xf3) [0x7f71dbf74f43]
./blender() [0x165481c]

Any idea what wrong?

It looks like there is an issue with your graphics card. Judging by the error message, I’m assuming you are on a Linux system. We really need to know your OS and version of it, your graphics card, GPU drivers, etc. to help more.

Jason

So it went a little like this:

cat /etc/fedora-release
Fedora release 30 (Thirty)

lspci | grep -i --color ‘vga|3d|2d’
01:00.0 VGA compatible controller: NVIDIA Corporation GT218 [GeForce 210] (rev a2)

lspci -v -s 01:00.0
01:00.0 VGA compatible controller: NVIDIA Corporation GT218 [GeForce 210] (rev a2) (prog-if 00 [VGA controller])
Subsystem: Micro-Star International Co., Ltd. [MSI] N210 [Geforce 210] PCIe graphics adapter
Flags: bus master, fast devsel, latency 0, IRQ 26, NUMA node 0
Memory at fd000000 (32-bit, non-prefetchable) [size=16M]
Memory at d0000000 (64-bit, prefetchable) [size=256M]
Memory at ce000000 (64-bit, prefetchable) [size=32M]
I/O ports at d800 [size=128]
Expansion ROM at 000c0000 [disabled] [size=128K]
Capabilities: [60] Power Management version 3
Capabilities: [68] MSI: Enable+ Count=1/1 Maskable- 64bit+
Capabilities: [78] Express Endpoint, MSI 00
Capabilities: [b4] Vendor Specific Information: Len=14 <?>
Capabilities: [100] Virtual Channel
Capabilities: [128] Power Budgeting <?>
Capabilities: [600] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
Kernel driver in use: nouveau
Kernel modules: nouveau

lshw -short
/0/100/2/0 display GT218 [GeForce 210]

lshw -class display
*-display
description: VGA compatible controller
product: GT218 [GeForce 210]
vendor: NVIDIA Corporation
physical id: 0
bus info: [email protected]:01:00.0
version: a2
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
configuration: driver=nouveau latency=0
resources: irq:26 memory:fd000000-fdffffff memory:d0000000-dfffffff memory:ce000000-cfffffff ioport:d800(size=128) memory:c0000-dffff

nvidia-smi
NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

*** INSTALLS DRIVERS *** DOH

nvidia-smi
Thu Feb 20 13:02:00 2020
±-----------------------------------------------------+
| NVIDIA-SMI 340.108 Driver Version: 340.108 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 GeForce 210 Off | 0000:01:00.0 N/A | N/A |
| N/A 39C P0 N/A / N/A | 450MiB / 1023MiB | N/A Default |
±------------------------------±---------------------±---------------------+

±----------------------------------------------------------------------------+
| Compute processes: GPU Memory |
| GPU PID Process name Usage |
|=============================================================================|
| 0 Not Supported |
±----------------------------------------------------------------------------+

Late night last night, had 2.7 running fine, but wanted to try 2.8 BlenderGIS…

Rubbish card on this machine but works :smiley:

https://www.if-not-true-then-false.com/2015/fedora-nvidia-guide/?PageSpeed=noscript

Thanks for consideration :smiley: