Select all rays when click on vertices/edges/faces

I’m having a problem when I’m going into editting in Blender. When I want to select a vertex, it only selected some of the rays that is linked with it. It happens when I want to select edges and faces too. I know that I can use shift to select those rays, but it wil waste much time when I have to select more vertices. Please Help.
Thanks for the help.

you have duplicate vertices present somehow. cntl a for select all then w remove doubles

You can also merge the closest vertices, or use the “circle selection”.

O i see… Haha, I thought i had change something with the settings. Thank you Star Ranger4