Select in 3d View - object in outliner not visible

When I select something in the 3D view, it “selects” it in the outliner. But the outliner tree does not expand to show the highlighted item. Is there an option to turn this on somewhere?

Specifically, I’m working on an armature with a lot of bones, many of which occupy the same locations (some bones are for animation, and some are for adjustments). So finding the highlighted item in the outliner is important, because many of the times, it selects the wrong bone (the animation bone), so I need to switch to the “adjustment” version of the bone.

If it’s not possible to automatically have the tree open to the selected item, is it possible to hotkey it?

Well, I can’t seem to find a way to make it automatically visible (if anyone can, I would appreciate it).
However, I can force it to focus the object by moving the mouse over the Outliner, and pressing the key to focus it. (F in Maya Mode).

Try this: Change the Display Mode of your outliner to Selected. It will automatically show you all objects you´ve just in focus.

Remember, you can have two outliners with diefferent Display Settings as well.