Select Linked and Seam edges

Hi there.
I noticed that the behaviour has changed:
When pressing “L” by hovering over a vertex (With vertex select mode) now it selects an island bounded by edges marked as seams. That used to only work for face select.
Any way I could get the old behaviour back? Is there a setting for that?

Don’t believe there is an option to limit this behaviour to a particular selection type

Damn it, that is so inconvenient…