Select Through Backface

In solid view, backface culling is enabled by default (which is very handy for getting an overview of internal spaces, with their normals facing inwards)- but the culled backfaces are still considered when trying to select things, so for example even though I can see all the edges in the below image, I can’t select them.


Is there a way to select things through a culled face? toggling on x-ray turns the screen into a garbled mess of verts and edges for anything but the simplest geometry, and also switches faces into the dreaded “you can only select by the little dot” mode so that’s not a solution.

Set XRay slider to ‘1’ for 2.79 behavior

I must be missing another setting somewhere, with the xray slider at 1 vertices and edges are still showing through un-culled front faces and faces still can’t be selected anywhere but at the center dot.

In order to turn off face dots you have to uncheck it in the overlay panel

1 Like

Maybe it’s a bug? That setting was never on and toggling it has no effect.

At any rate, my main issue is still that xray is kinda useless with dense meshes. It would be much better if I could just select through culled faces (but forward faces would still block selection so I can’t accidentally select invisible geometry without knowing it).

It might be work creating a proposal for this on https://blender.community/c/rightclickselect/