Selectable and unselectable vertices in the same object

I’ve been using Blender for about 3 years now, but I swear I’ve never seen anything close to this:
This is a single object, but I can’t select the right arm vertices. Looking at it on Egde select mode it seems strange because Select More/Less doesn’t work, although this arm edges CAN be selected one by one. But looking in Vertex Select Mode this seems a bit crazy because the vertices doesn’t even appear!
Vertex Select Mode


Edge Select Mode

It’s not a double vertex

I don’t know when this started, but I did some unusual steps (for me) in this model:

  1. After applying the Mirror Modifier, I Separated this right arm and did some further moddeling (the elbow pad) and then I have it Joined and Merged by Distance.
  2. I"m using Rigify, which I can’t see how could be affecting this, but I have never used before.

It may be a simple problem, and I’m sorry if it is. But I really have no idea of what is happening or how could I solve it.

Edit:
I can use rigify vertex groups to select vertices, but clicking the Seelect button in Vertex Groups panel with “DEF-Forearm.R” or “DEF-Forearm.R” does not select anything.
Edit 2:
If a face is selected, this is what it’s look like in vertex select mode:


SOLVED!!
Those vertices were just hidden (Alt+H to unhide):

I knew this was and idiot user problem, But I still can’t understand why everything was visible if vertices were hidden… BTW, sorry people!
In case anyone find this helpful someday: we’re both dumb HAHA

That’s actually isn’t an “idiot user” problem at all, but a bug :wink: This kind of vertex hiding isn’t supposed to happen - if a vertex is hidden, so should be edges and faces connected to it; there have been similar reports on the developer tracker, but AFAIK so far the actual source of this problem hasn’t been found. If you do happen to encounter a reliable way to reproduce this (i.e. a sequence of steps after which vertices end up in this weird hidden-not-state), please yell so we can relate the information to the developers.

1 Like

Well, thanks! I feel better now!
I’ll let you know if I find anything! :wink:

This is why I keep advocating for a conspicuous ‘flag’ to be implemented that signals when entities are HIDDEN or when LocalView is engaged.

When an experienced user such as the OP is stalled long enough to make a long post with SIX screengrabs, it tells me that maybe something is a little too subtle. I know that I (with a lot less experience) have been stalled for exactly the same reason – things were hidden, one way or another. How many other users have experienced the same massive speed bump, but just haven’t complained about it?

Such a flag doesn’t need to take up screen space: I note that this user has STATISTICS visible (I do too) – a color change in the appropriate line would be adequate. Certainly better than nothing.

(This same speedbump exists in lots of software: coming back from coffee with Photoshop with hidden selections can be similarly baffling.)

1 Like

I was about to suggest that this could be alerted in Stats panel. This may not have anything with the bug itself, but a coloured font warning me, or even remembering me, that I wasn’t looking at the whole mesh would have spared some time indeed.

1 Like

Yup. I suggested the same thing a while ago but got a fair amount of pushback: apparently some people don’t WANT Blender to be easier to use.

Such a feature is similar to After Effect’s “capslock border” flag: in AE, caps lock prevents the screen from updating. As you might imagine, if capslock is on and you’ve FORGOTTEN it’s on, it’s very mysterious as to why AE has suddenly stopped working. Adobe wisely made it easy to notice when capslock is ON.

Blender.org should exhibit the same kind of wisdom and care for its users.

tl:dr; Both “LocalView” and “hidden” states should be conspicuously flagged for the user.

The thing is, since the case in question is a bug, there’s no telling if any sort of indication would’ve worked, or worked correctly :wink: