Selecting audio device in exported runtime

Hi,

Any body knows how to use SDL sounds instead of OpenAL when using blenderplayer or a .exe created with “save as runtime” with blender 2.5 ?

OpenAL seems to make blender crash on windows when a sound is played several times :frowning:
And the choice of using SDL instead of OpenAL seems to be a only a user preference of blender, i found nothing for blenderplayer :s

thx

Are you using the inbuilt Audaspace for playing audio?:eyebrowlift:

Audaspace? What option is that - is it in the User Preferences panel?

I suppose yes. But I think audaspace uses SLD or OpenAL depending on blender settings.

It looks like the player has various settings hard coded:


	// XXX add the ability to change this values to the command line parsing.
	U.mixbufsize = 2048;
	U.audiodevice = 2;
	U.audiorate = 44100;
	U.audioformat = 0x24;
	U.audiochannels = 2;

Did this ever get fixed ? I need to force the audio output device to JACK audio. Audaspace docs mention returning an audio device name which suggests it can be set. However using “aud.device(3)” shows error message “does not accept any arguments”. I checked my exported executable (blenderplayer) for command line options using “-h” but no mention of audio apart from turning it off. Is it possible to force audaspace to select sound device ?

If not then I might be able to use the Alsa to Jack bridge kit but its not my favoured option at the moment.