Selecting Multiple Objects

I’m new to blender and have been following a series of tutorials on creating a character and rigging, but for some reason when I try selecting multiple armatures with shift+a, it doesn’t work. Niether does using the hot key b. I tried being in edit, pose, and object mode but it won’t work and I need to finish the project for one of my classes. I need to parent my leg and arm armatures to the spine, but since I can’t select multiple armatures, it won’t let me. Thanks for any answers. Let me know if I should upload my model as an attachment.

To select multiple things simply use Shift+Left mouse button when clicking things. You can use the A-key (not Shift+A) to select/deselect everything.

To parent things you should be in object mode. Normally you create a parent relation between a mesh and /an/ armature, not between two armatures (depends of context of course.) In most cases, the (armature) bones for legs, arms, and spine are all part of the same armature. The relation between them is a hierarchy within the armature, not a parent-child relation between separate objects (i.e. the armature is an object).

My fault, I meant to type shift+left click. Don’t know why I typed shift a. But yea, the shift left click isn’t working.

Also, the fact that I can’t select all of the armatures at once, no matter what mode I’m in, is what is messing me up.

Shift + right mouse button.


You can also right-click on an object name in the outliner to add it so a selection.

In object mode, shift+RMB will allow you to select multiple armatures, other modes are meant for selecting individual bones.

also, to parent your armatures to individual bones, you might be better off selecting all your armatures and then joining them (ctrl+j) so you could make your different parts actual children of each other.

Thanks ZombieJohn. In my original posts I made a few errors. I was using shift and right click to select multiple objects, but it wasn’t letting me select all of my armatures. After doin the ctrl j thing it worked though. Thanks again man.