Selecting object through object

Hello, I have two object - second placed inside first. When I click RMB on outside I select outside, but when I click RMB second time on outside object the inside object is selected. It is great and comfortable feature. But what should I do for turning OFF selecting object through object in Solid and Texture Viewport. I hope clearly wrote what I mean, In short I wish to select only this what I actually see. Is it possible in Blender? Thanks.

Alt+RMB will give you a popup window from which you can select the desired object.
Of course, you can always disable object selection using the Outliner, too.

I am Debian user, left ALT + RMB gives window system info: minimize, maximize… I must hold two ALT buttons and press RMB - it gives blender Select Menu popup window, but it is not what I mean. I have already assigned for double click LMB to “Cursor to Selected”, and double click MMB to “Center View to Cursor” for me it works excellent. I wish also to assign double click RMB to toggle Edit Mode / Object Mode on selected object.

You have my sympathies, you need more mouse. Get a newer mouse with back/forward and scroll right left buttons and you’ll have 7 buttons to play with.

thanks, 3 buttons mouse is sufficient :slight_smile: I set double click speed to 500, and now looks OK

My latest mouse buttons config:

Single click LMB = Select (Select with: Left)
Double click LMB = Select in Edit mode (3D View -> Object Non-modal add object.mode_set Mode: Edit Mode, Toggle checked)

Single RMB = put cursor
Double RMB = Snap Cursor to Selected (3D View -> 3D View (global) view3d.snap_cursor_to_selected)
Dragging RMB = move 3D cursor (Enhanced 3D cursor Addon)

Double click MMB = Center View to Cursor
I have troubles with assign to single MMB click, but will try again.

Anyway there should be option to turn OFF selecting object through object in Solid and Texture. There is Wireframe Viewport, and is not problem to turn to this mode for selecting not visible objects.

It is not OK on Debian. When I select “Select with: Left” I can not use use loop selecting. When click SHIFT+left ALT+LMB it not work - displays like in attachement WINDOW DEACTIVATE.