Selection in Edit mode


I work with an object which consists of several forms which are not connected one with other (but all vertices belong to one object). Like for example if you would have two cubes, sphere and another sphere all joined together under one object.

So these objects are not connected with each other by any edges/faces/vertices. But do overlap in my scene.

Now the problem which I started to notice from 2.47… or maybe 2.75 is that i cannot select one single object in edit mode no more. It gives me only one of these options under “L” key: Normal/Material/Seam/Sharp/UV. However none of them would select only those vertices that are connected with each other no matter what and ignore those which arent.

With older versions I remember L key in edit mode/vertex select gave me the results i was expecting. But not anymore.

Is there something I am missing or this feature is moved to somewhere else? Thanks

Select one vertex and use Ctrl+L to select all its linked vertices or press L while the cursor is over a vertex

These are using the default keyboard shortcuts and work correctly in the current blender version. If you are not using default settings then use the shortcuts you have assigned

Oh, I always used just L while mouseovering the needed part. So I guess now it works like you’ve described. Thanks, will give it a try!

And which mode should I use now? Normals?

As Richard Marklew says, nothing has changed in how L-key select did work in 3dview edit mode.
See if your User Preferences are not changed:
Options by default stay on Seam and now selection is limited by seams in vertex select mode also in addition to face select.

Okay, so in other words, if object is seam-marked already that fact might get in a way of selecting whole bunch of connected vertices with one hit of an “L”?

Yes, if Seam is the default option. Ctrl-L should work but it’s a bit of a finger stretch.