selection problems

probably a really stupid question, but is there anyway you can ungroup objects? I have imported a few objects all with different colours within the objects, but when I select one component of one object that happens to be the same colour of another component of another object, they are both selected and I end up moving parts that i dont want to.
can anyone help?

The materials are linked.
Click the object you want, and make sure you have the correct color selected in the Materials Buttons panel. Next to the color’s name (if you just imported, it is probably something like “Material.002”) is a little button with a number on it which indicates how many objects are linked to that material. Click it and you’ll get a popup asking if you really want to “Make Single User?”. Click and now you have a new material (“Material.007” or something like that) that is only linked to the current object.

Now you can change the color without affecting the other objects (because they are using a different material).

Hope this helps.

While in edit mode press P to seperate either selected vertices or loose vertices from your mesh into a new mesh object.


In edit mode, select a single vert, then ctrl-l to select all verts belonging to the same mesh.

Best of Luck!

Ah, yes, my bad. I should have read “moving parts” more carefully.:o

I think if you’re importing .obj into blender you have three options to ‘split by object’, ‘split by group’, ‘split by material.’
Also your other program may or may not have options in the export menu that will allow you to export color, object, group, etc as object.
are you saying all your objects are coming in as one object in object mode and you have to go into edit mode to move them around?