Self-compiled cycles build won't work

Hi everyone,

I’m running into a problem when running cycles. It compiles fine but when I run it this error comes up:

[james@********** bin]$ ./blender
connect failed: No such file or directory
ndof: spacenavd not found
found bundled python: /home/james/blender-svn/build/bin/2.60/python
Fatal Python error: Py_Initialize: Unable to get the locale encoding
LookupError: no codec search functions registered: can't find encoding
Aborted (core dumped)

Build flags:

 CMAKE_BUILD_TYPE                 Release                                      
 CMAKE_INSTALL_PREFIX             /usr/local                                   
 WITH_BUILDINFO                   ON                                           
 WITH_BUILTIN_GLEW                ON                                           
 WITH_BULLET                      ON                                           
 WITH_CODEC_FFMPEG                OFF                                          
 WITH_CODEC_SNDFILE               OFF                                          
 WITH_CYCLES                      ON                                           
 WITH_CYCLES_CUDA_BINARIES        OFF                                          
 WITH_CYCLES_TEST                 OFF                                          
 WITH_FFTW3                       ON                                           
 WITH_GAMEENGINE                  OFF                                          
 WITH_IK_ITASC                    ON                                           
 WITH_IMAGE_CINEON                ON                                           
 WITH_IMAGE_DDS                   ON                                           
 WITH_IMAGE_FRAMESERVER           ON                                           
 WITH_IMAGE_HDR                   ON                                           
 WITH_IMAGE_OPENEXR               ON                                           
 WITH_IMAGE_OPENJPEG              ON                                           
 WITH_IMAGE_REDCODE               OFF                                          
 WITH_IMAGE_TIFF                  ON                                           
 WITH_INPUT_NDOF                  ON                                           
 WITH_INSTALL_PORTABLE            ON                                           
 WITH_INTERNATIONAL               ON                                           
 WITH_JACK                        OFF                                          
 WITH_LIBMV                       ON                                           
 WITH_LZMA                        ON                                           
 WITH_LZO                         ON                                           
 WITH_MOD_BOOLEAN                 ON                                           
 WITH_MOD_DECIMATE                ON                                           
 WITH_MOD_FLUID                   ON                                           
 WITH_MOD_OCEANSIM                ON
 WITH_MOD_SMOKE                   ON                                           
 WITH_OPENAL                      ON                                           
 WITH_OPENCOLLADA                 ON                                           
 WITH_OPENMP                      ON                                           
 WITH_PLAYER                      OFF                                          
 WITH_PYTHON_INSTALL              ON                                           
 WITH_PYTHON_MODULE               OFF                                          
 WITH_PYTHON_SAFETY               OFF                                          
 WITH_RAYOPTIMIZATION             ON                                           
 WITH_SDL                         ON                                           
 WITH_X11_XINPUT                  ON

Try to not include python binary ( delete/rename /home/james/blender-svn/build/bin/2.60/python or compyle with WITH_PYTHON_INSTALL = OFF), maybe it is conflict between system python library and compiled.

check if you have python 3.x on your system, i don’t know if that solves your problem as i build on windows only.

It works now! Thanks :smiley: