self-plotted texture is blurred

Hi community,
I’m currently working on a mechanic to dynamically draw a minimap for a dungeon crawler project.
While drawing itself works fine the pixels are all blurred as if mipmapping was active (which I disabled).
Do you have any idea how I can get crisp edges for the pixels?

Thanks in advance :slight_smile:


minimap.blend (481 KB)

Last time I commented about mipmapping, it turned out I was wrong, so I will just say:

  • Try it after exporting it, or use the ‘standalone player’ button

Otherwise, because plot supports custom brushes rather than individual pixels, it may be easiest to use a higher resolution texture and just not use the extra detail.
Another thing you could try is a fragment shader with the ‘greater than’ option:
(Yes you can use node materials with custom textures)
This operates in screen-space, so will make the transitions sharp to the user. However, since the pixels are blurred, it will come out with rounded corners.


Thanks for the quick reply.

  • The standalone player doesn’t make any difference.
  • Unfortunately using the shader approach isn’t an option for me because each block on the minimap needs to be a sqare perfectly aligned to it’s neighbours. It should look like a map of an old rogue like game.
  • Scaling up the image buffer sizes does indeed make the corners sharp. So I’d use this approach if noone else comes up with a more “memory friendly” solution.

Big thanks again :slight_smile: