Sensitivity on zooming with scroll wheel is unusable

I’ve been using the mac version of blender recently on my work computer, and all of the sudden the zoom sensitivity while using the scroll wheel is unusable. It used to work before, but now just moving the scroll wheel one increment makes it jump way too much.

Here’s a link to a video showing my problem:

I’ve tried reinstalling blender, and using different mice. I’ve also tried reducing the scroll wheel sensitivity on the mac but it made no difference. Does anyone have any suggestions on how to fix this? I’m aware I can use ctrl+mouse3 to zoom in and out smoothly, but seeing as I’m used to using blender on windows, this would be too much of a burden to get used to.

Did you try to restore your default setting of Blender?

Just tried that.
No difference unfortunately.

I have found that there are differences when zooming in orthographic view and perspective view (toggle with number pad 5).

It works a lot better in orthographic for me.

Try changing your Zoom settings to continue, instead of Dolly:
2022-04-07 10_31_32-Blender Preferences

Hi. I tried this morning. No difference.

Hi. I just tried this now also. No difference.