Sequencer cache removes alpha from strip 2.80, 2.81, Windows 10

I have a transparent image sequence that I want to be able to preview in the sequencer, but when I cache the strip it simply disables the alpha and I don’t know why, but from testing this multiple different ways I think it’s a bug. I really want a work around though.

I have to be able to preview that strip against a background which is not possible due to this issue.

I’ve tried scene strips, as well as EXR multilayered, regular EXR and png. Every time I try to cache, without fail blender rips out the alpha.

I’ve tried in both the stable 2.80 build and the latest 2.81 build on windows. Anyone else having the issue?

Perhaps because Blender uses a jpeg image sequence for proxies, jpeg does not support an alpha channel.

Interesting… but surely there will be something other than jpeg processing or at least a way to modulate maybe a second alpha channel to handle this? Or is this a feature we should ask for?

I asked years ago but was told that proxies are for performance playback. png or other alpha formats are not quick/small to encode/use. So I don’t think that it will ever happen, sorry. You could render out an alpha channel pass (B&W) then use that as a mask modifier source?

When you use an internal alpha input, it shouldn’t matter whether it’s jpeg, png or psd. You plug it in to the right slot, it knows that it’s alpha. I’m talking about the alpha being it’s own image.

You can do it in compositor, output alpha to jpeg, output color to jpeg. Then take another file and input the color jpeg into the color of the final image a d the alpha jpeg into the alpha of the image output. This is not so much a tutorial to follow but a point I’m trying to make about what the most obvious thing is in my mind… You can interpret two jpeg files as the one. Why does the cache not split the color and alpha and inherit the two jpegs as seperate channels?