Sequencer crash with filename length > than 36 chars

Whilst creating my Tug concept using the sequencer I discovered a problem with the filename length when bringing in TGA images. If it’s greater than 36 characters in length, excluding the extension, it will crash blender when you move the image or images to the current frame marker.

I have reported this to the Bug Tracker, but I wanted to give the heads-up to blender sequencer users as it wasted a good 40 mins as I tried to resolve the problem.

One might say why do you need filenames over 36 characters in length? Well when I am working on complex scenes with many layers I find it easier to identify the correct filenames with more descriptive titles. I find this useful when I have many strips in the sequence editor to.

Anyway just keep those filename lengths down below 36 characters and you will be fine.


Good work, and thanks. :wink:

:o :x

Thank you! I have been having this problem, too. But it doesn’t crash. Instead it “changes” the filename on the strip from sequence/image0001.tga to sequenceXRmage0001.tga and only displays the first frame. It has been driving me nuts while I try to find another editor with the same power as Blender (could not find any)! I moved the folder containing the sequence to C:\ and now it works fine. Thank you again!

[edit] Oh. It does crash when I render it. But it changes the name when I load it into the editor and watch it from there. [/edit]


PS I hope they fix this because moving these particular folders to my desktop is ruining my nice and neat folder hierarchy. :<