Serious problem with GE - [solved]

Hi, I have a problem with BGE

I download this: http://blenderartists.org/forum/showthread.php?t=137038
And when I open it:
http://s4.postimage.org/d60m0.jpg

When I start the game:
http://s2.postimage.org/R4BAJ.jpg

Also not play smoothly, like watching a slideshow of pictures…
It does not matter whether something is complicated or a one polygon… And in log, note “Shaders not supported!” What caused this?

Blender System requirements:
Minimum
CPU 300 MHz
Memory 128 MB
Graphics Hardware OpenGL graphics card with 16 MB RAM

My graphic card is GeForce FX5200 (128MB), and I have 256MB of RAM. My processor is AMD Athlon 1800+ (1.5GHz) , and when I start the game, loaded to the max:

http://s4.postimage.org/68J0i.jpg

Where is the problem? Please help!

Do you mind not naming the images swear words please…

Sorry, I fixed it. I thought it would be renamed when upload images…

I’m pretty sure the problem is that your graphics card doesn’t support GLSL. Blender’s GLSL page says that the Geforce FX is supported. I would suggest updating your graphics card drivers. You might get GLSL support then.

Blender’s system requirements are not the same as a game’s system requirements. Just because Blender will run doesn’t mean that you can take a game with amazing graphics and run it at 60fps.

Also, the reason it seems like a slideshow is because your graphics card is really old. I have a GeForce 7300(512MB) and 1G of RAM. I only run that demo at 10 fps.

About the CPU Usage: Blender always uses 100% of one core, no matter what game it is.

P.S. What BlendFace said

Not on Linux.

Woah! Really? Another tally on my reasons to install Linux.

Problem is due to OpenGL. Can Blender work with D3D, not OpelGL?

P.S. Why Blender developers, not provided an opportunity for choice?!
…or and they follow “the tradition” - forcing you to buy the latest computers… :mad:

No, the problem is not with OpenGL. OpenGL works very well when it is properly supported. The problem is with your graphics card driver. It has poor support for OpenGL. Are you using the default graphics driver from Microsoft? You should update your graphics driver with a more recent driver from the company that made your graphics card (nVidia). Go here:
http://www.nvidia.com/Download/index.aspx
Your card product series is “GeForce 5 FX Series”

No, it cannot. Blender is a cross-platform open source program. Unfortunately, D3D only runs on MS Windows operating systems. If you would like to see cross-platform D3D support (making D3D a more viable option for use in Blender), then please contact Microsoft and request that they either port it to all Blender supported platforms or open the source so that others can do so.

Blender developers have actually taken the harder, less traditional route by offering an opportunity for choice. For example, I use Blender on Linux. By using OpenGL, the Blender developers have given me the freedom to make this choice. If Blender used D3D, I would be locked into developing on a MS Windows operating system, or I would be unable to develop with Blender at all.

No one is forcing you to buy a new computer. I used to develop Blender games with an Intel Pentium III 733 Mhz processor, 768 MB system RAM and an Intel i810 32 MB shared system memory integrated graphics chipset. On Windows 98 SE. And that was back when Blender GE was much slower than it is now.

Thanks! But now I have a problem - uninstall the old drivers, restart the PC and then “new hardware found” and automatically install the same (old) drivers. What should I do?

the drivers should come as an .exe that installs the new drivers in place of the old ones. You should not need to uninstall the old drivers manually.

If you do uninstall old drivers manually and restart, then you need to select the new drivers manually and use the “Have Disk” option and point to a directory where the .exe installed the new drivers.

Thank you very much! GLSL already working, and everything is in order!

You can delete the topic if I have new questions will be released a new theme.

We do not delete threads. They might be interesting for other readers as well. If you are happy you might add “- [solved]” to your thread title by editing the top post. This signals that a solution was found.

Thanks

Glad to hear everything is working now. :smiley: