Set Dimensions in Edit Mode

Works for me, currently using Blender 2.82a… Thank you.

Guys, this thing is broken in 2.93.0…When I do a Set Dimensions in Edit mode, it just has “New Dimensions:” in an empty box and no ability to enter any values whatsoever. Sadly, I use this damn thing multiple times per day… : - ( Can the dev fix this please?.. Today if possible!. Chop chop! ; - )

Anyone?.. This is pretty dang urgent. Or if there is some other way to set dimensions on x/y/z of selected verts, edges and faces in Edit Mode in Blender 2.93.0+ (with exactly the same results as Set Dimensions script), please, I beg you, edify me! I really, really need to be able to do this!

I’m actually volunteering at a camp with restricted access to tech, so I’ll look at it if someone pings me again in a couple months. Sorry. Look at the threads that have linked to this one and you might find a workaround, otherwise do your modeling in an older version and bring it up to 2.9 afterwards

Also, I don’t make any money off of this add-on. There is no obligation whatsoever on my end to support it. So just be careful of your expectations with this and most other Blender add-ons.


Personally, I’m still working on version 2.8, but it will definitely be time to move to the next level.
This addon is extremely helpful, so if you decide to develop it in the next versions of the blender, I will be able to support you financially without hesitation.
Just put it on blendermarket or gumroad :slight_smile:

Calm down bro… my pleas were meant to be lighthearted/comedic, and I am very sorry you took it as some kind of nasty command. Maybe a nice nature walk could help. Enjoy camp. ; - )

… and yes, I too would plunk down some dough to have this ability again in 2.93.0+…

In the meantime, if any other devs want to make a nice competing addon that does exactly what Set Dimensions does, myself (and possibly Nanomanpro) and presumably others will have money waiting for you.

1 Like

You see if this “CAD Mesh Dimensions” addon is useful for you:

Before installing the addon you will probably need to install the python xxhash module. In Linux if you have “pip” installed you do from the terminal “pip install xxhash” (or “/usr/bin/python -m pip install xxhash”). In windows I have no idea, you see if you can install the addon by default without installing xxhash.

1 Like

YAFU do the cad tools work in 2.92? Or 2.83.16? On the download page they are being used on 2.91.Thanks

I have only tried installing the “CAD Mesh Dimensions” addon, I have not tried the other addons. I tested it in master (3.0), and installing it in the way that I have explained.

1 Like

Sorry, I don’t mean to be harsh, but I can’t really determine tone over text. And it isn’t uncommon to be pressured on open source projects to make changes (even by users who aren’t paying anything). I could try to sell it, but that is a lot of effort for something that might already be replaced by the actual Blender devs (IDK…haven’t been keeping up on it recently).

Selling add-ons isn’t quite what you might think it is though in terms of returns. This might get one or two $5 purchases and that’s about it. And if it takes, say, 20 hours to make, then it is not going to even come close to minimum wage in the US for sure. A software developer can make far more than minimum wage, so it is really a waste of time unless you have something groundbreaking. So we generally make these add-ons because they are useful to us, we just want to give back to the Blender community, or we are having fun learning how to make them.

Also, there’s no need for a “competing” add-on. Mine is on GitHub with a license that allows anyone to copy and redistribute it as long as they keep the same license (most Blender add-ons have the same exact license, even if you sell on Blender Market).

The fastest route for you would be to nicely ask a developer (perhaps hire a freelancer if it is really important and you are willing to pay like $100 for it…that’s probably a ballpark of what it would be for a one-off) to make a pull request that fixes it on the repository that’s already on GitHub. Chances are it is just updating it to use a new library for getting values. I’m guessing the rest of it should be essentially the same.

1 Like

Would probably be best to make a different thread, but you can definitely link between the two if these solve the same problem.

I think this could be a Blender limitation, it is not a CAD program after all:

You could create a new thread in Modeling section for asking about how to “set dimensions in Edit mode” and you briefly and respectfully talk there about the alternatives that you have found and the problems that you are having.

The code is super short and you can read it right here if you’re curious:

What he is saying is that Blender itself is not designed to be a CAD program, so you’ll never get perfect accuracy even so. If you type imperial measurements into a field in Blender, it isn’t stored exactly right in the backend even if it appears correct in the UI. (Just tricks that can be done in the background to make it look right)

1 Like

Gotcha. Wonderful. Carry on (with camping etc). Thanks bro!

MACHIN3 (MACHIN3Tools dev) was kind enough to solve the 2.93.0 woes for Set Dimensions:


    new_x = FloatProperty(name="X", min=0, default=1, unit='LENGTH')
    new_y = FloatProperty(name="Y", min=0, default=1, unit='LENGTH')
    new_z = FloatProperty(name="Z", min=0, default=1, unit='LENGTH')


    new_x: FloatProperty(name="X", min=0, default=1, unit='LENGTH')
    new_y: FloatProperty(name="Y", min=0, default=1, unit='LENGTH')
    new_z: FloatProperty(name="Z", min=0, default=1, unit='LENGTH')
1 Like

I think that was fixed in this pull request

Okay. Regardless, it is working now. :+1:

Good that is working, I mainly said it because some people might miss the fix since it was posted more than a year ago (the raw.githubuserconten, link)

Just following.