Set Dimensions in Edit Mode

Can someone Update this to blender 2.8 Beta :smiley::smiley:

Still works for me. Just downloaded the latest version using Blender Version Manager.

With blender 2.8 ?

Work fine for 2.8 after changing the line 107 from :
box.label(“New dimensions:”)


box.label(text=“New dimensions:”)

And changed the name to “blender”: (2, 80, 0),

it works just fine .

Specials thanks Zimlorog ,
Thanks for the support and the great blender community :smiley:


As a Modo/C4D user I was looking for this precision setting as well.

Thank you Graphic_Dev and everyone else who commented on how to modify it to work with 2.8!

Thank you Graphics_Dev. This is exactly what has been missing from edit mode for my accurate modelling.

OMFG, this has been the missing link for me! Thank you thank you thank you! I was still doing my modeling that needed precision in LightWave, but I think those days are possibly over. Is there any way we could get a toggle checkbox to constrain/lock proportions? That would make this kickass addon almost* complete (see below). Here is how Absolute Size works in LW - They call Constrain “Locked”:

*The only other thing I can think of that could also make this nearly perfect would be to have a toggle to allow full non-rounded values be displayed in input fields when not selected. The rounding is really nice for some things, but when working at very small scales rounding is undesired, if one is trying to work fast and not want to have to select a field to see the actual value of the field.

Thanks again! You’re a lifesaver!

Edit: It just occurred to me that the rounding stuff may only apply to those of us who work in Imperial (feet, inches, mils)… So to expand on this a wee bit: If possible, I need to be able to work (fast) with stuff that has values like 72.0625" (72 1/16")…

Sorry Benny, but that does not help me in any way. Like I said: “if one is trying to work fast and not want to have to select a field to see the actual value of the field.” So hopefully the dev can add the ability to see full values without fields selected. That would rock. Almost as much as the proportion locking…

Yes , you are right that would be better to have this option by default :smiley:

Thank you Benny_G, and Zimlorog.

1 Like

This is great !!!

Just a quick update to build upon knowledge already shared by Benny_G, and Zimlorog.

The Mesh Tools AddOn is now distributed with Blender 2.80, but does not (Yet?) include the Set Dimensions tool. Thus I initially ran into an AddOn instillation conflict when installing Set Dimensions because it still references MeshTools in its code.

To fix this I opened the file that was downloaded from GitHub with Microsoft Visual Studio Code and changed all references of “Mesh Tools” and “MeshTools” to “Set Dimensions”. Though really the only reference to “MeshTools” that needs to be altered to make the AddOn work harmoniously with the current version of Blender 2.80 (July 5th build) is:

Line 28: “name”: “Mesh Tools”,

So to sum up, to get Set Dimensions to work with Blender 2.80 as of July 5th 2019 edit the following lines of code in the file:

Line 28
From: “name”: “Mesh Tools”,
To: “name”: “Set Dimensions”,

Line 31
From: “blender”: (2, 78, 0),
To: “blender”: (2, 80, 0),

Line 107
From: box.label(“New dimensions:”)
To: box.label(text=“New dimensions:”)

I also changed the version number:

Line 30
From: “version”: (1, 0),
To: “version”: (1, 1),

Just because.

Anyhow, I hope this adds to the chain of help for the next individual utilizing Blender 2.80 and seeking a tool like Set Dimensions. I know I was elated to find it.

P.S. A special thank you to the original developer of this AddOn, Graphics_Dev, if they are still around.


Thank you for the instructions to update this to 2.80. Also a long time Lightwave User, and modo, and I missed being able to specify Exact Measurements, for any dimension and have the other two conform. Is there anyway to push the ‘corrections’ to GitHub? or is that subject to the developer only?? I have made the changes as suggested. Thank you.

SyntaxError: invalid character in identifier
fake_module: addon missing ‘bl_info’ gives bad performance!: ‘C:\Users\paulhart\AppData\Roaming\Blender Foundation\Blender\2.81\scripts\addons\’
Modules Installed () from ‘D:\downloads176\MeshTools-master\’ into ‘C:\Users\paulhart\AppData\Roaming\Blender Foundation\Blender\2.81\scripts\addons’

1 Like

Are you able to publish the adjust file so it’s easy to install and use in 2.8? Also does it work in 2.81.

Hello, friends.
After the amendments proposed by debCreative
I’m trying to install this add-on in version 2.81, but an error occurs.
Can I ask for help with the update?
I attach a modified file.
Thank you . (3.7 KB)

@juliushibert @paulhart2 @Nanomanpro Does this pull request work for you:

Raw file here for this pull request:


Works for me, thank you very much :slight_smile:

Works for me, currently using Blender 2.82a… Thank you.

Guys, this thing is broken in 2.93.0…When I do a Set Dimensions in Edit mode, it just has “New Dimensions:” in an empty box and no ability to enter any values whatsoever. Sadly, I use this damn thing multiple times per day… : - ( Can the dev fix this please?.. Today if possible!. Chop chop! ; - )