Set keyframe in pose mode - all keyframes for bone are changed to new pose

I’m trying to animate a pistol, and the bone I have for the trigger is doing something odd. When I enter pose mode, pose the trigger bone, and try to set a keyframe (using ‘I’ or auto framing) it sets all other keyframes for that bone to the new pose. Also, in the action editor, when I expand the bone’s keyframe properties, many of them are underlined in red.

It was working up to a point, so I imagine I did something silly, and can’t figure out what it is.

Here’s the .blend file:
FPStest.blend (606 KB)

Thank you.

Strange. Not sure what you’ve done here to cause these to be considered to be errors.

To clear the red-line errors, just use the “Revive Disabled F-Curves” function from the Action Editor -> Channels menu. From testing here, the problem doesn’t seem to come up again afterwards.

With the “it sets all other keyframes for that bone to the new pose”, are you referring to the scaling of the bone’s pose? If so, it looks like you only animated Loc/Rot for this bone initially, and then started using LocRotScale after keying the rest, so the scale-values are not animated for frames where you have keyframes set for the other transforms but not scale (with extrapolation taking care of those values, leading to the values you see)

I’m sorry I forgot to include some information. I appended this model from another blend file. Deleted the original file (I thought appending it put the whole file into the new .blend), got some errors, so restored them. The error showed up some time after that. Not sure if that’s what caused it though.

And to answer your question, it overwrites all the keyframes. I did not use scale at all. I think I may have uses a LocRotScale KF for the first one, but only needed LocRot after that. Should I just use LRS keframes for all of them?

Also, I tried your suggestion and it worked, thank you very much! That was driving me insane, haha.