set Speed of baked (recorded physiks)

I wonder how to set up the realtime playbackspeed in blender game engine.

I made a simple setup. If push “p” you can see the physics workin. It looks to slow to be real
After enabling “record animation” the physiks got “baked” to keyframes.
Somehow its much to slow. I could scale it in the graph editor to speed up but there must be some setting in the ge… If i remember correctly there was some setting in 2.49.
How can i setup the “world” speed in 2.6?

Attachments

ge1.blend (489 KB)

OK, several thoughts, not sure if any is going to help.

  1. You can go to Render > Display > Animation Frame Rate and change it to anything you want. If you want to see its effect when you hit Alt+a you’ll probably have to go to the Timeline and set Playback > Frame Dropping.

  2. Scaling the keyframes is not really that bad of an option. It will work 100% of the time.

  3. Your collision bounds are not set optimally. To see them you can go to Game > Show Physics Visualization. This can greatly improve the in-simulation performance, but I don’t think this should have an effect on the resulting keyframe speed.

  • The “Sphere” should be a “Sphere” boudns, with Physics > Radius at about 50cm.
  • “Cube” should be a “Box”, but there is a challenge: it has been rotated and rotation applied. To get the right Box boundary you will actually have to go into Edit Mode, straighten it out, then go into Object Mode and rotate it back. I found that it is tilted by about -7.474°
  • “Cube.001” is the same as “Cube”
  • “Circle” is the trickiest. It should be “Cylinder” bounds, but this bounds type aligns with the object’s local z-axis. So, to get it to work you will need to do an Edit Mode select all then r,x,90 plus an Object Mode r,x,-90.

I hope some of this helps - if not please let us know and we can look closer.
-rking