Setting background color in Blender Render, not showing in render

So, I’m doing a super basic animation in Blender render (not cycles), and I’m trying to get a bright green background to key out, and while it’s showing up in the rendered viewport when I actually render the animation it’s still gray. I have alpha changed to sky and can’t really figure out what’s going on.

@hamman91 How are you rendering your animation out? Image sequence? If so you can just set the background to alpha transparent and it will render out an alpha channel background providing you are using an alpha supported image type.

I tried to set it to be transparent and while there’s a checkerboard background in object view, there’s still a white background when I render. Is there an option I’m unaware of?

Second Image:

Third image:

What do your output file settings look like? Make sure you have it set to rgba

Yup, it’s RGBA