Setting up the grid for real-world modelling

I have been away from Blender for some time - back now, and I am running 2.6.6.

I want to model a piece of furniture approx 1.8m x .7m x .9m.

The grid, in default mode, is unhelpful as I need to model elements of the furniture in mm - for example, the feet are 61mm x 79mm x 27mm and I would like to model with the grid set to millimetres.

If I change the grid so that I can model in millimetres, I have to change the grid floor to 2000 to see the whole item (2m), but the max number of lines is 1024 and anyway the grid then vanishes altogether when I zoom out.

Whatever I set the grid to, a 1 x 1 x 1 cube doesn’t appear to correspond to the gridlines - I have the cube at 1 x 1 x 1, with the grid set to lines 100 and scale 1 with 10 subdivisions, but the cube occupies more than 4 squares of the grid.

Also, the grid is in a single dimension - is it possible to see a grid in the other two dimensions?



Attachments


Open the N panel and enter in Dimensions the size you want for each part you are modeling.
Model each part separate. Then you select two objects and join them in one single object with /object/join in the menu
When the model is finished recalculate the normals (edit mode, T panel Recalculate), and apply the scale (object mode menu object/apply/scale ) so it shows scale 1 in the N panel.

Great suggestion - seems obvious now you point it out. But did you notice my point about the grid not reflecting the values in the N panel? In the screenshot you will see that the object is 1 x 1 x 1 and the grid is set to 1 with 10 divisions, so the cube should take up exactly one square on the grid, but it actually occupies more than 4 square. Why is this?

The tooltip on the N panel of the Grid Lines say that is only for perspective viewports. Change the number of lines to 2 for example and only in perspective viewport you will see the grid has now 2 lines.

About the cube not being the size you expect, I would have to look at the file to know the exact reason, but probably the dimensions are not what you say (look its dimension in the N panel).

Another trick: Sometimes it is difficult to model in mm. Instead you can model working in meters. So one piece of 4 mm you just model a piece of 4 meters. Then when you finish the model press S .001 enter, to scale the object again back to mm.

Or instead doing the above you could go to the Scene panels, Units subpanel and enter a Scale there of 0.1 for example and you see the default cube is now 20 cm and not 2m that was previously. I change this better than the above, but the two methods avoid one problem where you can go with the camera very near of the object and only can watch the object from a distance in perspective mode. Also it avoids to have to use things like 0.004 for 4 mm. For example with a scale of 0.001 you just use 4 for 4mm. But my preferred is Metric system with 0.1 for the Scale

ok - somehow i had only a subset of options on the N window - probably from inadvertently hitting keys… now I have a dimensions window! thanks for the tip…