Shade Smooth Malfunctioning

Shading issues appear when I change an object from Shade Flat to Shade Smooth. One end of the cables turned out beautifully. The other end looks like it is missing faces, which it is not. I began with a cylinder. I then extruded and scaled and inset the object as needed to create the shape. Save for the two round faces on the end, all the faces are quads. Normals are correct. Moved the light. I have scoured the internet all day looking for someone with a similar issue and tried those fixes, but nothing seems to work.

New users are not permitted to attach files. If you reply with an email, I can send you the blend file.

Here are photos of what is looks like.

Bottom:

Top:

Normals:

I think it may be flipped normals, select all verts in edit mode and shift n.

Thanks for responding. As per the post and the last photo, the normals are correct. Any other ideas?

HMm, didnt see that. maybe duplicate faces on top of it? Not sure, can you post a simple version of the blend?

When I tried to add an attachment when I created the post, I was not permitted to add it. It now seems like it might work. Attachment below. If it is not, please reply your email so I can send it.

AAFA.blend (1.2 MB)

You have some double vertices in there. Edit mode > M > By distance seems to solve that.

After that I went into mesh properties and turned auto smooth on with a value of 80 degrees:

image

That seems to have solved it (visually at least). I would double check your mesh for additional errors.

Thank you! :star_struck: When I tried removing duplicates in other versions, it still produced a weird shadow and made it look soft. Everything else I found online said to turn off auto smooth so I did not think to use it after removing duplicates. This really helps me out so much!

To avoid this in the future, is there are way to create the same shape without producing duplicates?

Your welcome. :+1:

The way you described modelling the antenna is perfectly valid and shouldn’t lead to double vertices normally. So somewhere you made a little mistake but I can’t really think of how. Its good to be mindful of creating valid geometry (Blender calls it manifold) while you model but sometimes in the process you just create a bit of a mess, it happens to all of us. That is a part of the modeling process and you will get better at it as you gain more experience.

I feel the more important part is that you are able to spot mesh errors and fix it. You already started troubleshooting by checking for normal direction which is a good first step. In addition blender has a really nice tool under Edit > Select all by Trait > Non Manifold.

This will select the elements in your mesh that blender considers “Non Manifold” which is just a fancy name for errors in your geometry. After calling it up you get a little panel in the lower left corner of your viewport which allows you to turn on and off the various errors Blender checks for. You can toggle these on and off to see what exactly is wrong with your mesh and then fix it. Sometimes its as easy as merging vertices by distances, sometimes you have to go in by hand to fix some stuff.

Hope it helps. :slight_smile:

1 Like

one way duplicates are created is when you extrude but don’t actually move the verts anywhere, so you hit e, then the dog barks, and you hit enter without moving them. Also you select partial loops by box selecting without xray enabled. I always do shift select on a loop to make sure I have the whole loop.

1 Like

:exploding_head: wow friend, that is really helpful. Next time, I shouldn’t have to use an entire work day to solve such a tiny problem. Thanks.

I feel like I have so much to learn. This was much easier seven years ago in college when I had a professor to bother and didn’t realize how complicated of a tool blender is. There is a big difference between mastery and following directions.

Anyway, stay golden.

1 Like