Shaded Mode not Showing Textures 2.66

The texture links aren’t broken, I reloaded and replaced. But still the textured mode looks like I have no textures in the game (when I start the game too). Yay new Blender :smiley: Did I miss a new setting?


Maybe try to download some new svn revision after 2.66, theres been some fixes?

In shaded mode you are not supposed to see textures. It is the purpose of the texture mode.

Oh, my bad. Textured mode doesn’t show anything. I feel like an idiot :o The textures ARE there though. I hit F12 and they render out fine.

Which version of blender did you use before 2.66?

Try to use “Help” => “TexFace to Material Convert”

In this case, I discovered the same issue with 2.65 just three days ago. But i have hat at my laptop without glsl support (2.63 is fine). At the laptop with glsl support the textures appear fine even in multitexture mode.

iFlow, that didn’t make it work :\

Monster, is open GL support the same thing?

I had this problem when I upgraded to 2.66. The lightmaps were showing from the nodes but the main texture was black… to fix it, I went into the main texture and picked “UV Map” for the tex coords… for some reason it un-assigned itself when I upgraded. Hope it helps

I checked out that kind of stuff and no settings were changed, and I saw some objects with a texture but the texture was not unwrapped correctly. Really frustrating :frowning: I even tried making a new .blend and the textures won’t work.

I can confirm this issue, still not resolved, something to do with UV channel and Texture blending. it glitched and selects the wrong one.

Ive moved back to 2.65a and textures are fine again.

Have you reported this?

Yeah I’m having the exact same problem. :confused:

not had chance to report yet, i still need to create a example blend

edit 14/03/2013:

Problem for me Fixed in 2.66a


For me this is not related to Multi UV

So this is my bug:

My issue is solved.

I needed to turn of user preferences/system/GPU mip-map generation.

Yeah my textures disappear as well in the game engine still. I really want to use 2.66 so I can have 128 resolution shadows instead of 512 so my game will run smoother but that problem is substantially out-weighed by not having any textures. :confused:

Maybe you need other settings. Just play with the buttons ;).