Shadeless in cycles texture mode problems

I’ve got an animation all set up and I’ll render in openGL in the Texture display mode. The trouble is, only some objects are truly shown as shadeless. Even though Shadeless is selected in the view properties, some objects are still affected by the openGL lighting. What am I doing wrong?

Here is an image showing the objects in material mode using emmision materials:

And here shows the problem in Texture display:

Any ideas?

Use Holdout for the black? Disable Diffuse and Glossy for Cycles on Object tab?

No that didn’t work. But thanks for trying. The issue is in the OpenGL view. Some items are STILL getting the OpenGL shading even when the Shadeless option is checked! Very frustrating. :spin: