Shadeless material in 2.8?

I’m mixing the Principled BSDF node with an Emission node to get a shadeless material in Eevee.

Now I’d like to use the Base color of the object as the emission Color but I can’t find a way to get that from the Principled BSDF or with any other type of node either.

Second question, I’d like to copy this setup to all other shapes in the imported svg, how do I do that? Scripting, or is there any easier way?

The shadeless node setup from the Import images as planes-plugin is quite complex, what am I missing by just mixing with an emission node?

The principled shader is pointless for a shadeless material. Shadeless materials are just emission shaders with color. That’s it.


How do I get the original base color from the imported shape?
I find no other node that gives me that color to use in the Emission node.

The base color is in the shaders. If you have shaders that are mixed and have masks, you just have to mix their colors using the same factors and use that for the emission color.

To share a color between nodes:

I guess I’ll have to create a script that reads the base color of a shape, then use nodes and creates an emission node of that color.

I want to have an svg of many shapes and colors to be flat shadeless. To do it manually for each of the containing shapes is not an option I’d like.

I found that a very good shadeless solution exists in the import images as planes add-on, found when you indicate shadeless from the settings when doing the import.

Thank’s Craig. I like that one as well but I can’t get it to work on my shapes. Everything turns purple…
I’ll investigate a bit more.

in 2.8 you may need to turn on use nodes in preference material panel
then it should work fine

happy cl

Probably it is looking for an image texture to be input.