Shaders GSoC Branch -- Testers needed!

From my blog:

As I had noted in my status report for last week, I wanted to get some builds up so people could start testing the branch.

Here is a win32 build:

Here is an OS X build provided by Gomer:

Here is a Linux i386 build provided by Hendore:

Here is a .blend file that can be used to start testing some features. It includes a simple toon shader (vertex +geometry + fragment) that demonstrates the following:

  • Ability to control some rna values (in this case diffuse_color and alpha)
  • Ability to add and control custom uniform values
  • Ability to use geometry shaders

http://www.pasteall.org/blend/3164

Unfortunately, I couldn’t get the texture color working in the geometry shader, but it works in the fragment shader…

Cheers,
Moguri

Hello Moguri
Nice work man!
I´m having some fun with this feature, really useful!
With your demo i had some problems in 3D view like that:

http://img408.imageshack.us/img408/5576/testeglsl.th.jpg
It´s right?

My specs:
Windows XP SP2 32bits
NVidia Geforce 9500GT
Driver 197.45

Whatever, its a really nice add to BGE!
Bye!

When I tried to open the built this error message showed Up saying that the vcomp90.dll was missing i just took the file from the alpha build and put on your build s folder.
I dont know how to use this for me appear only a white object when I press p.

I have a nvidiaGTX 260, i think that s the only information that you ll need right?
Pelase ask what you need and i ll provide, thanks for your help improving the bge

I saved you some hassle, I’ve uploaded a Linux build of your branch.

I’m now using blender to learn GLSL and see my changes happen in real time :slight_smile:
Thanks Moguri.

@vitorbalbio
Yes, that is the expected result. The geometry shader essentially uses the duplicated mesh trick to achieve the outline. However, the 3d view always draws both sides of a mesh, so the normal trick doesn’t work. I’m looking into adding an option to disable this so the viewport can better match the BGE. Also, the geometry shader isn’t all that great since I don’t really know what I’m doing. :wink:

@leonnn
That’s strange. A GTX 260 is more than capable of running this stuff (I’m using a Geforce 8600M GT). Could you please post a screenshot and the output of the console?

@Hendore
Thanks for the build, I’ll update the original post. :slight_smile:

OW its working for me, I had pressed alt z, now its working. like balbio s screen shot.

I had forgot to test in the viewport, but you demo .blend works fine for me on win7 64 nvidia.

And thank you very much for this :smiley: Diffuse and alpha control will be handy.

Works well for me. I imported an old file of a man on steroids into it to see how it worked. Runs at a solid 60fps.

http://www.youtube.com/watch?v=PeLL6Ie8Mns

My specs:
Windows 7 Home Premium 64 bit
NVIDIA GeForce 9100
6144MB RAM