shaders not supported!

I’ve only just noticed that I get this in the dos window when running games. Is there something I can do about it (without replacing my graphics card) Im running the full 2.46 for windows version?

Cheers

You can request ARB shader support, but I doubt that will happen. Unfortunately there’s not much you can do except get a new card.

Sorry for the bad news.

Yah, I can’t run them either, but, how many games have you seen (made in BGE of course) that actually use GLSL or the shaders???..that’s what I thought…

~Túrin

@ denshidan:
What gfx card do you have? Are you using the latest drivers from the manufacturer? If not, a driver update might help you out. Also, what is the OpenGL support that Blender lists for you when you launch the game engine? For example, I get this:

Detected GL_ARB_texture_env_combine
Detected GL_ARB_texture_cube_map
Enabled GL_ARB_multitexture
Enabled GL_ARB_vertex_program
Detected GL_ARB_depth_texture
Detected GL_EXT_separate_specular_color
GL_VERSION: 1.3 (1.3 Mesa 7.0.1)
shaders not supported!

@ Venom:
Silly rabbit, Blender already has ARB shader support. Check the listings I just posted. The real problem is that nobody knows how to use it (except for those who implemented it and recently fixed it) and nobody has written any widely accessible ARB shaders for Blender yet.

@ Turin:

I think the main reason that nobody uses GLSL shaders in their games is that they aren’t well supported. Look at how many people have posted since 2.46 saying “I want to use the 2D Filters, but I can’t because my gfx card doesn’t support them.” There is an obvious desire in the community to use these advanced features, but as of yet the features have not been integrated in a way that is accessible to the BGE community at large.

I know that I personally probably won’t be using shaders in any of my games until they are reliably supported even on Intel integrated chipsets, for example. Please understand that I am not saying this to be rude to the developers who have implemented GLSL shaders and support into Blender. Much of the problem actually has to do with poorly written drivers from gfx card manufacturers who do not offers proper OpenGL support even though their cards are capable of it. If you have a graphics card or chipset which does not have driver support for GLSL shaders, perhaps you should write to the manufacturer and politely express your disappointment with their lack of support, telling them that proper OpenGL support will be playing a major role in your future graphics card decisions, and if they have not stepped up their support by that time the can expect to not receive your business.

Woops! Shows how much I know = )
(I’m very new to this, obviously)

Okay so say I generate an ARB shader with qshaderedit. All the shader code is there, now we just need some documentation on how to load the shader in blender games.

Since there’s not any out there, how would I find out who integrated ARB shaders into the engine?

I get

Detected GL_ARB_texture_env_combine
Detected GL_ARB_texture_cube_map
Enabled GL_ARB_multitexture
Enabled GL_ARB_shader_objects
Enabled GL_ARB_vertex_shader
Detected GL_ARB_fragment_shader
Enabled GL_ARB_vertex_program
Detected GL_ARB_depth_texture
Detected GL_EXT_separate_specular_color
GL_VERSION: 1.5 (1.5.4647 WinXP Release)
shaders not supported!

Ive got a RAdion x300 series (ATI) video card

I just updated my driver and now I get

Continuing happily.
Detected GL_ARB_texture_env_combine
Detected GL_ARB_texture_cube_map
Enabled GL_ARB_multitexture
Enabled GL_ARB_shader_objects
Enabled GL_ARB_vertex_shader
Detected GL_ARB_fragment_shader
Enabled GL_ARB_vertex_program
Detected GL_ARB_depth_texture
Detected GL_EXT_separate_specular_color
GL_VERSION: 2.1 (2.1.7537 Release)

Does this mean shaders are now supported? I still get flat colour in texture mode whist running my games…

Its really weird…if I flip the normals so I cant see them in object mode I can in game mode and vica versa… any ideas?

Hello
“your games” maybe don’t use GLGS shaders?!
If you want to download this little demo you can verify if it works:
http://blenderartists.org/forum/showthread.php?t=125207
Bye

OTO

your game crashes blender for me

???
Sorry, I don’ no what to say?
What’s your “specs”?

I get shaders not supported too but I can use normalmaps in GE

If you download this archive, you’ll find inside a “GLinfo.blend” that will print
in the console if your graphics card support the different shaders/technologies
http://www.continuousphysics.com/ftp/pub/test/index.php?dir=blender/&file=graphics-demos-2.43-preview1.zip

Hi there OTO,
I stumbled over this thread because I can’t get realtime shadows in the game-engine.
I also got the shaders not supported messege (by the way I use a vanilla 246 version of Blender)

I did the test with GLinfo.blend. as you suggested:
Every question in the console had a yes behind it, so I would think everthing is ok, but then again I still got the shaders not supported message.
I wonder what to do now?
I realy like to have shades below my moving objects.

Greetings to you

Jbal

Mr. Oto you have the knowlege I seek. Since this box image renders properly in test play, I just apply your tequniques (after scrutinous examination) to my own Images, objects and logic and <cheezy particle effect> I get test play with those images applied?

i get a message thats a little different. it says:
Detected GL_ARB_texture_env_combine
Detected GL_ARB_texture_cube_map
Detected GL_ARB_multitexture
Detected GL_ARB_vertex_program
Detected GL_ARB_depth_texture
Detected GL_EXT_separate_specular_color
shaders not supported!

what does any of this mean???

Well, you can use “Texture Face” and “Multi-Textures” in the “Game” menu, but not “GLSL”
Bye