shadin porblem in BGE

I have a character with basic materials on him,but when i press P it is rendered shadeless,why is that?Is there any way to fix this?

Do you have GLSL materials turned on? If not, press the “Game” menu and select “Blender GLSL materials”.

ok now this is extremly odd it says my driver or card does not support GLSL materials,i also tested on other blender files and it’s the same,which is extremely odd because before it all worked well,with shading and all,it is very odd

EDIT:I checked an older file,which was made with a older version of blender and that one works fine,so i don’t understand what the problem could be

EDIT: No,it’s not dependable on the blender version,i checked naother file and that one is fine

Go to Game and check Blender Multitexture Materials. That should fix it.

did not work,also i am not using textures,only materials

well i foud a solution,i moved everything to 1 layer,wich is odd because the lamps did not have layer toggled

Well, then this is odd.

You said “before it worked”. So, when you say “before”, what are you referring to? Before you installed the newest version? Before you updated your drivers?

before working on the project,anyway it is fixed