Shading Artifacts with New Render Engine

I’ve been messing with the Radeon Prorender engine in Blender 2.79, and it works wonders so far. The only issue I seem to be having is the appearance of these line artifacts appearing in the render. You can see them in the middle of the mesh, where the mouth of the hood is located. They don’t seem to be in response to any light source and they don’t even conform to the geometry, as you can tell. Is there a way to get rid of these lines?

Line artifacts like these can be and issue with precision on the GPU. Try a render with CPU only and see if they remain. I had an issue like this with LuxCore as well, and this was their answer, so this could be a similar issue with RadoenPro Render, but ever since version 1.5 I haven’t been able to successfully install/run it, and the RPR guys haven’t been much help. Love what they’re doing with it though.

There’s a setting “Ray cast epsilon” under RPR Render Quality. Play with values.
Be sure to apply Scale and check geo, … and all the stuff that matters for precision sake.
Always do as much as possible, describe specs + post an exemplary file to get better, proper help.

I used both techniques, and together they eliminated the problem completely. Ajm, switching to CPU knocked out most of the lines, and burnin, upping the ray cast epsilon setting smoothed over the rest. Thank you both for your input.

Ajm, I noticed that when using both GPU and CPU to render, the artifacts are still gone, which is great. But I also noticed that there is an ever-so-slight difference in lighting between this method and simply using CPU only. The results don’t make that much of a difference, but I’m still curious what the cause is. Could this be my GPU’s fault? It’s an AMD Radeon R9 M395.

If the artifacts were caused by my using the GPU, does this mean it’s faulty or outdated? I’m not really up to speed on what is considered more powerful or not.

CPU only


No, the GPU is not faulty, it’s how they are designed. CPUs have to be versatile and have a good amount of calculation depth and therefore are more precise, GPUs not so much. What you give up in precision you make up for in speed, in a way. Think of them like a river and a lake. The river moves swiftly but it not as deep (the GPU) and the lake is deeper, but the waters more calm (the CPU). In this example the water represents the data that each can handle, and the current the speed that each handles that data.

The artifacts that you see can arise from material type and/or even scale of the object. Try sticking to real world dimensions as much as possible to eliminate the scaling issue, materials can be a minor issue, but as you have noticed, in some cases parity between each processor type might not exist. If RPR is using OpenCL in the same way LuxCore does, then the GPU is responsible for the raycasting calculations, and the CPU does the material/surface calculations once the ray hit come back from the GPU, that’s why you see the artifacts disappear when rendering with GPU plus CPU, and why they aren’t there in CPU only mode. Rendering on GPU only, the GPU does both tasks, and like above, may not have the precision to calculate your material correctly.

1 Like

Ajm, thank you very much for the thorough explanation. I took everything you said into consideration, and my render looks top notch now. And what’s more is I have a better understanding on the render engine itself.

You mentioned earlier about not being able to successfully install RPR since the 1.5 update. I’d welcome you to check out their website since they have a 1.7 version right now (for Blender), which I managed to install with no problems.

I did have a quick question on speeding up my renders. I switched to RPR to cut down on rendering time, and when I first used it, it was unbelievably faster than Cycles. Over the next few days however, I saw a dramatic decrease in performance speed and I can’t pin down exactly where it’s coming from. Does RPR have a cache folder of sorts? Does it have anything to do with my own GPU/CPU specs, and if so, what would be a good option for upgrading? I’ve seen other people use RPR and experience less-than-a-minute renders (as opposed to my current 6+ minutes), and I could really put that to use.

AMD Radeon R9 M395
3.3 GHz Intel Core i5
Retina 5K iMac

It could be your hardware type, but I would first look into ray bounces. Like I said, I have had trouble with the installation of RPR on Linux recently, it tells me that it can’t load something from it’s python modules, like it’s missing or something, but here is a little advise.

In many cases more than 3 bounces of diffuse is more than what is required. In the case of RenderMan the default is 1 as a good starting point, I usually stay around 2-3. When it comes to transmission of rays though transparent materials a good start value is 6, reflective materials start at 3. See if you can get away with less samples with passable quality and take advantage of denoising. All these settings are on a per scene basis, and not meant to cover all scenarios.

On another note, RPR may be using a cache to load in scenes that have been rendered before a bit faster, since Brian, the product manager came from Pixar, which could mean that there are files saved out per scene, but this would just speed things up, and since I haven’t been able to use RPR recently, I’m not sure about that. I will give the install another try and ask the team for help with my roadblock and I might have a better idea of how far they have come.

1 Like