Shading Issue On Model After Export As .GLB/GLTF

Hello, I’m trying to do some ArchViz Models and upload them to Sketchfab.

I’m uploading my model as .glt/glb but when I upload them to the shading is broken. In Blender everything looked fine but in Sketchfab you get these very visible seams, almost like a shading issue.

The problem apparently specifically occurs with the .glb/gltf file. Even When I import the file back into blender I get the same isse. So the export is somehow broken I guess…?

Does anyone know what’s causing this error in the .glb/gltf file and how to fix it.

Looks like NORMAL problem. Try reset normals before upload.

Thanks for you reply. Can you please further elaborate what you mean exactly. Because the normals seem too look alright. Is there anything else you could tell me that might help?

By normals, I believe they mean Face Orientation. In your Viewport Overlays, turn on Face Orientation. Anything that is Red is flipped/backfacing, and will present issues. Select those red faces > Mesh > Normals > Flip

Thank you for your response but using the face orientation overlay shows basically the same thing as the image i posted above. My normals look perfectly allright, so that cannot be the problem.


I also figured out that the problem only appears in the .gltf/glb version of this model. So I’m going to further explore this on that front. Maybe something went wrong when exporting the model.

I’ve found the solution.

Apparently it is necessary to save out the textures before exporting as .glb/gltf otherwise you end up with this glitch. This also happens when you tell the .glb/gltf exporter to export your images as ‘JPEG Format’, so don’t do that.

I don’t know if this is a bug or something like that because it doesn’t happen with .fbx format.

Anyways saving out your textures before exporting will solve this issue.

A personal question from me for future references.
Was embedding textures the cause of this issue originally?