Shading quirks with Freestyle and Toon shading

I have this fairly basic scene with all meshes using (materials with) Toon shading. I have the render mostly as I want it, but there are a few problems with it. If you look at the D-pad (the model in the scene is a gamepad) closely, you can see some uneven shading, a bit like crumpled paper; the diagonal, ovoid buttons have black lines partway along one side; and the circular buttons are not filled in with the colour of their materials, and have some grey from surrounding object.

[ATTACH=CONFIG]384024[/ATTACH]

I have very little experience with 3D modelling, so while I understand the basic concepts involved here, I have no idea what is causing these rendering quirks. Can anyone offer any advice?

Attachments

nesish_gamepad_and_cord.blend (522 KB)nesish_gamepad.blend (565 KB)

It’s perfectly possible that I didn’t have enough coffee yet this morning, but somehow I don’t see a gamepad mesh in the file you uploaded - just the cable and an empty? Which makes it a bit hard to comment on shading issues with that particular mesh…:wink:

Ah, oops… That would be because the gamepad mesh is in an external .blend, and I thought “Pack All into .blend” would pack linked data, not just non-Blender data, like images and text files. I have edited the attachments on the original post, and it now includes both .blends. Sorry about that. :S

a)
Most of your problems are caused by the Boolean cutter objects in the nesish_gamepad.blend:
You have set their maximum draw type to “Wire”, which will make them mostly unnoticable in the viewport, yet they are still being rendered. And because they occupy almost exactly the same space as the button meshes, the geometry overlaps and causes render artefacts.

So, in the nesish_gamepad.blend, disable those cutters’ renderability (camera icon in the outliner) and save the file.

b)
As far as the the ovoid buttons are concerned, play with the Freestyle settings for edge detection:


Ah, yes, the cutter objects… I had forgotten about those. >_<

And playing with the Freestyle settings is getting me the look I was after.

Thanks for the help!

By the way, I swear I posted a reply to your first reply, but it seems to have not gone through. Sorry about that; I didn’t mean to respond to your reply with only an edit. :stuck_out_tongue: