Shadow artifacts on faces

Not sure if you might be able to help me on this one. I am using Blender 2.49b to create models to be used in a realmcrafter engine game.

When I create a model such as a building and export it to Realmcrafter in b3d format I get bad shadows on the faces that have extrusion.

Here is an example:

I have looked at lots of tutorials and had advice from people on the RC forums but so far I cannot rectify this problem. I’ve checked to make sure I’m set solid too.

can anyone offer any suggestions?


Bump ?

Surely someone here might have the answer?


Set the shading to flat before you export. See the toolshelf > Shading > Flat.

I can’t find that ! I’m using 2.49b. Do you mean shading > smooth?


best would be to UV map it, and bake the texture and lighting, imo.

Surely it’s just a matter of find out what I’ve done wrong? It looks to me like the model is being exported a smoothed rather than solid. Other people are using Blender to export into RC without this problem. They can’t workout why I’m getting this result when I export.

Is there a ‘shading > flat’ option that I can’t find or does the poster above actually mean ‘set solid’?