Shadow being cast has texture in it - why?

I’m still trying to debug this one. I’m back to the basics relearning blender and I’m looking at a simple render I created awhile back to test some techniques. It’s a couple boards with wood grain texture with a couple sun lamps and spot light and a plane for the background. The shadow cast on one baord from another looks right, but the shadow cast on the plane from the board has the wood grain texture in the shadow. What is happening?

could you upload the .blend file? This sounds like something you are simply missing or something like that. Maybe the floor has the same material? Or maybe that is a setting that you can put on to make the shadow just calculate the texture of the object thats casting it or something. Just post the .blend.

Is it actually the wood grain texture, colored, perturbated and all? Or is it just concentric rings? If it’s concentric rings, then that’s a shadow-mapping artifact. Raise the shadow lamps’ bias settings until it goes away.

The bias of the spot lamp had no effect. I was going to change the bias of another lamp to see the effects. Simply selecting another lamp and rendering the scene changes the color of the render (without making any other changes than a selection). Now I’m really confused. Why is it doing that now?

Baboon, I’m trying to figure out how to upload the .blend file to this post but I don’t see how.

Check if your spot has a wood texture applied on it.

Serialsiner.

Good suggestion. No textures are applied to the spot or any of the other lamps.

Now I can’t reproduce the render changing when I select one of the other lamps. This is very odd.

Yasoo2, if you don’t have webspace could you just e-mail a pic and/or the belnd file. I will upload it untill the problem is solved.
(Please be kind, I only have 56k :wink: )

Hi. I guess it’s not really the texture I’m seeing. I moved stuff around and got a bigger area of shadow to look at. It’s a repeating rainbow affect or maybe what harkyman said. A series of concentric rings.

So I can’t upload it here? I have webspace that I could use, I just didn’t know how things were done around here.

Here’s a link to a .jpg of the render and the .blend file. I just can’t figure it out. I’ve spent hours trying to get rid of those wierd colors in the shadow but to no avail.

http://home.comcast.net/~yasoo2/index.html

Harkeyman already gave you the answer… Bias. You can also change the bufsize. Not sure though why you need so many lights in there.

%<

Increasing the bias doesn’t work for me. Neither does increasing the buffer. Neither does doing both.

I have that many lights because I was just playing around for experimentation to see the effect.

You should decrease the Bias, not increase it.

Martin

I tried that too and it doesn’t work. That makes swirls all over the background plane.

Without being pedantic I have to say your problem doesn’t warrant the effort we’ve all put into it. Your basic mistake is the lighting setup. Move the spot. Get rid of 2 of the Suns. Use lamps. Turn onlyshadows off. But, most of all search for tuts (there are litterally hundreds of them) on basic 3-point lighting. What you have produced is an artifact within a .blend that can’t even be considered a wip. Personally, I’m willing to help where I can but expect some kind of cooperation. If you have the same kind of prob in a wip then post it, but here I must honestly tell you that the first thing I did when downloading your .blend was to delete the 3 suns, turn off shadows only and drop the bias to .7
All this said in good spirit!

%<

actually , I cant see what the problem is, the render looks very normal to me, and the blend file renders exact as the render you put up, though I see in the blend file that you have some not assigned textures…I think it would be proper to upload the correct render AND correct blend file with correct assigned material and textures, before you start to moan…

and btw…I am no administrator, but…I have seen you have posted several questions on each new post, instead of asking many questions in the same THREAD, which would be much better AND nicer…seems you have bad patience :stuck_out_tongue:

be patient, we Will answer in time…and also, be sure to put correct thing before you post/upload stuff…

ztony

Maybe you could pay a little closer attention to my other posts before you get into me like that. Each post is regarding a separate issue and has nothing to do with this one. I don’t believe they belonged in the same post. Most newsgroups I belong to like one topic per post. I wasn’t aware that it’s any different here. Not to mention they occurred at different times. I have plenty of patience, thanks.

By the way, the problem is that the shadow looks like repeating rainbows, just like the posted picture. Thanks for looking at it for me, I figured out the problem now because of what you said. See below if you are interested.

Fligh,

What is a wip? Do I not seem willing to cooperate? I’ve been at the mercy of people replying to this because I just haven’t been able to figure it out. Until now. (see below). Just to give you an idea, I did that lighting on purpose because it gave me the colors I was looking for. That .blend file was a stripped down version of my original .blend file I was using to debug this issue. It was a file I created over a year ago with version 2.23 and I haven’t used blender since. I knew the render didn’t look that way before and I thought it was something I was missing about some setting in the 2.28 version.

I figured out the problem. After reading ztony’s post about how his render looks exactly like my posted pic and that they both look fine, I came to the conclusion that something about my video settings must be skewed in some way. My system was set to 16 bit high color. I switched it to 32 bit true color and it looks awesome. Man it looked ugly in 16 bit color.

Is there a way to render for a particular color set?

as in rendering to a limited palette?
no

Martin

as in rendering to a limited palette?
no

Martin[/quote]

must be just that, what he means…

as in rendering to a limited palette?
no

Martin[/quote]

Maybe not a palette, but how about rendering for 16 bit color?

render in 32 and reduce in your favorite image editor.

Martin