Shadow Buffer Error?

Not sure what is casing this. Same set up, only difference is a shadow buffer. As far as I know this is needed to get shadow in a halo which is why I am using shadow buffer. Any idea why it may be doing this?

Set up images are the Ray and Shadow settings

Other images are:

Render with the ray setting - Top Right
Render with the buffer setting - Middle Left
Halo with ray setting - Middle Right
Halo with buffer setting - Bottom Left


Good news! This is pretty easy to fix.

Keep in mind that buffer-shadows take a little bit of tweaking to get just right. You can’t just turn them on and expect them to be perfect. Once you get a grasp of their settings though, they’re often the best option, being faster and more controllable than ray-shadows.

The leak here is caused by a bias error. Bias controls how far two faces must be from each other before a shadow is cast from one to the other; it’s used to prevent an object from casting shadows on itself (self-shadowing).

To fix the issue, you can do any of the following.

  1. Switch from Classical to Classical-Halfway, which uses the new irregular buffer technology. In most cases, this offers significantly better shadowing with fewer biasing issues.

  2. Lower the Bias value. The Classical buffer seems to offer best results with a bias value between .300 and .400.

  3. Change the ClipStart and ClipEnd to more closely match your geometry. The buffer shadows are computed using a Z-buffer, whose minimum and maximum ranges are bounded by ClipStart and ClipEnd values. The tighter the range, the more accurate the shadows.

Personally, I’d use all three.


Nice, I’ve been looking for such an option for a while now.
One question though, is there a way that you can make the shadow edges from the shadows that come through the window more pronounced?

That’s great. Thanks for the brilliant mini tutorial.

As a result I looked for and found this:

Some technical background info on it.

I fixed the shadow error - mostly. But now the halo is bleeding. Not sure why. I am using displacements on a subrurf object. Not sure if that could be causing a problem or something else. In any case I employed all three suggestions and also increased the shadow buffer size.

Here is the set up and result.

Thanks for the help so far.


Absolutely. Increase the Halo Intensity value and the edges of the light-shaft become more pronounced.

You’re very welcome. :slight_smile:

That problem is really strange. I’m not at all sure why the halo is bleeding. The subsurf shouldn’t have any effect on it, but until I have a better idea, I suppose I can’t rule it out. Nothing looks out of place, either.

If you post a blend file, I’ll be happy to take a look at it.

Nice stonework by the way!


Great example! I really do like the volumetrics in Blender. By the way thanks for the compliment of the stone work. It is a WIP for sure,but getting there.

Yeah this is strange.

Here is the blend file.


StonesTestLight.blend (212 KB)

I figured it out. :slight_smile:

Turns out that Halos have somewhat unpredictable effects when they hit single flat faces. They apparently terminate a random distance after hitting one. For predictable effects, an object must have a front and back. Why? I haven’t the foggiest idea.

So, add a back to each of your stones, and it should work as intended.

Now I need to go scratch my head for a while.



Great illustration. Great job figuring that out!

It’s interesting. Actually come to think of it, I ran into a similar thing in LightWave. If you have a polygon facing away from a light it will not cast a shadow. This sort of makes sense when you figure the ray has to hit something. In LightWave all polys are single sided by default. So this means a ray is passing though the polygon from the back and no shadow will occur. The ray has to hit the face of the polygon. Even though Blender has a double sided button it may have a similar effect with halos regardless. Just a theory. But I do remember using “recalculate outside” which I get into the habit of doing. If you look at my final example you can see that the floor - which faces the light - appears to create a volume shadow beneath through the cracks. So there may be some truth to this theory.

Thank you very much for your time and effort!



Very instructive post!
Thank you very much - both of you !

:wink: :wink:

You’re welcome. It is always great to connect the dots with other information - if that theory is true. And thanks again Spectre-7 for pointing the way. :o

Very glad I could help! :smiley:

Wow, so that is why halos don’t work all the time. I have experienced that but just kinda went on.

OK, I have encountered another problem and some additional information along with the solution.

It seems to be that the Classic-Halfway is what creates the Halo problem with a single poly. But there is a new problem I also found solved again with a solid object.

Here are three render examples all with simple single polygons.

  1. Irregular setting - Gives the correct shadow but no Halo.

  2. Classical setting - Gives incorrect shadow at the corner but correct Halo

  3. Classical Halfway - Gives same incorrect shadow and incorrect Halo (as discussed)

And he solution:

A solid object as the wall. Works in classical and classical- half way.