Shadow catcher additional noise in alpha channel

Hey guys, im trying to render something with a shadow catcher but i get insane amount of noise that i can see when i look in the alpha channel. i hope you guys can help me out!

im using a hdri to light the scene, i have also tried to use an area light but it gives that noise aswell. if i put my sample count higher the noise gets finer but thats not the problem. the shadow from the object is perfect on 32 samples but its just the additional noise around the object that i dont want.

i can only put 1 picture cuz im a new user but i included mulitple screenshots

pic 1: as you can see, looks just like a normal cube on the shadowcatcher with a nice shadow, no problems here.
pic 2: now i if take a look in the alpha channels its shows this mess… i just want the shadow from the cube, nothing else.
pic 3: here is my scene setup with just the cude, shadow catcher, camera and hdri as light.
pic 4: here is a frame without the cg and shadow so you can see the big difference.
pic 5: cuz if i put it onto some footage its noisy all over the place…

any idea whats causing this? am i missing something or? thanks!

Are you kidding 32 samples ? Isn’t 128 the default (and maybe some more are better, try denoising and enable the denoising data pass to compare).

32 samples is high enough if you denoise. i have tried at 1024 samples but its still there, just less with finer noisy. the images is already denoised aswell but alpha channels dont get denoised. but thats not the problem, the problem is that their is noise outside of the cube shadow.

Okay maybe i was a little fast… i’m eager to learn so i looked into shadow catching etc. heard about but didn’t used it much to nothing at all.

So, i wonder why using a denoise node in composite but maybe that’s not the point. In 2.93 i also have for Render Layer this outputs (with pass denoise data) : Denoising Depth, which gives something like a mask ??? and Denoising Shadowing which is the shadow… and not that overbleeding alpha (which i overlooked at first).
Maybe this helps ? (im curious of your progress).

thanks for your reply, i appreciate it. and yeah i guess that might work to denoise the noisy shadow but then still, there will be shadow where i dont want it to be :confused:

above is what i need to get and below is what i have currently but dont know how to get rid of… (i just painted black over the area i dont want in photoshop rn to visualize)

Yes is understand and this is also what i understood about shadow catching … :thinking: your box is not iluminated ?? Looking at the pure shadow one miht thing that this is a lighted cube… Even if color black stength to 0 ??? (just a thought)…

For some reason denoise node don’t work with the RGBA output, but can be added to an alpha output, them use as a fac input in a merge node set to multiply, black color. Use a color ramp to fine tune.

To render separatly, create two scenes and two collections:

In the main scene, right click your SHADOW collection > View Layer > Set Houldout
In the shadow scene, right click your OBJECT collection > View Layer > Set to Indirect Only.

You can try this