Shadow Catcher - object properties

Hi. Simple question. This happened to me before and I do not remember how I solved it.
I am activating the shadow catcher box in the object properties. The mesh is still visible. Am I missing something on how to make it work?

Thank you

Cycles is still active, maybe you have copy of the mesh active?

I found it. The settings should be film>transparent