Shadow clipping near edges in EEVEE

Anyone know why this happens. Shadow clipping near the edge?

Attached is an image, also check out the video link.

Shadow clipping video link here

EEVEE Shadow Clipping on Edge.blend (806.0 KB)

I guess everyone is just as stumped about this as I am. :frowning_face:

a single screenshot with no supplementary information isn’t much to work on. share a .blend file and people will take a look.

There is a video.

Yes there is a video, but if there was a Blend others could check to see what the issue actually is. I’m going to guess that it is due to your scaling the plain in object mode.

Thanks, but I don’t think that is it. I’ve attached a simple .blend file in the original post.

This is an artifact of the filtering algorithm. Reduce the Softness to near zero, and bump the number of AA samples, since you’re already using soft shadows.

I’m generally not a fan of the shadows implementation in Eevee, it’s quite unreliable and requires lots of tweaking to combat its many problems.

Thanks. I suspected as much.

It’s a pity that I have to sacrifice softness to get the shadow to extend to the edge of the plane.

You’re getting much more accurate jittered soft shadows though.

The softness filter is just a cheap trick which only has one advantage - only requiring one sample. Good for playblasts. Crap for image quality.

adust the radius of your light to get softer jittered shadows

Ah, interesting! Thanks for that.

miketche,

The issue is that with the VSM shadows and “Soft Shadows” On and adding a large amount of point light shadow “Softness”. Eevee shadow map calculation does not have enough resolution.

The solution to the shadow clipping is to increase the shadow “Cube Size” to 4096. Alternative decrease the light “Softness” to 0 and increase the light radius as recommend by SterlingRoth.

The high value of light “Softness” creates unrealistic shadows. Notice that shadows close to the object are soft and it should be sharper than the shadow further away from the object. It is recommend to set point light shadows “Softness” to 0 for realistic soft shadows. High value of “Softness” can also create light leaks.

For correct shadow settings check my link on Light Leaks.