Shadow Compositing problem

Hi everybody!
So, i was messing about trying to mix some 3d animated stuff with a photo, when all the sudden i am stuck.

here is what i have so far

The problem comes when i try to had on the shadows. Because of the way the lights are setup, the 3d transparent staircase casts a shadow onto itself. I want it to receive shadows, the one from the matchboxes, but not it’s own.
I’ll send a render of those bad shadows soon, which should make my whole point obvious.

Basically, I need to know if one can and how to set a object’s material so it receives all shadows but it’s own.

Anyone has any idea?
:confused:

In your shadow only material settings, under Render Pipeline are two buttons named “Tracable” and “Shadbuf”. These buttons cause the material to cast Ray Traceable shadows and Shadow Buffer shadows. Turn both of this buttons off.

Cheers dychotomatt!! Gonna give it a go, but i’m pretty sure already that’s exactly what i needed.