Shadow issue, 3 point lighting

Hello guys, I am new to Blender and BlenderArtists.

I am trying to render a very simple model using the 3 point lighting system but the shadow is not smooth. What am I doing wrong?


The setup -

Most likely a geometry problem with the vase, but could be some particular way that shadows overlap. The file would tell more than the screenshot.

That’s not a geometry problem, it’s a direct lighting problem, and that’s not 3-point lighting. 3-point doesn’t just mean 3 lights.
Key light = main light
Fill light = another light source, usually coming from the other side of the key
Rim light = light usually coming from behind
Change those or move those around as you will, but it’s usually done with Area lights. Also try to turn on Environment lighting to soften the shadows. Also, smooth shadows on Area lights come from Samples, turn them up at will. Higher = Softer
But yeah, we could use your file, so please upload it :slight_smile:

To expand on that typically only the keylight casts shadows. So pick one light to be your shadow caster and turn off shadow casting for the other two. There is a three-point lighting AddOn floating around, I believe…

Now I really want to see that file! AFAICT nothing but geometry could cause that little discontinuity 1/4 of the way up from the bottom of the vase. It’s not where two shadow borders intersect, because that’s just above …

Dithering should clear that up, but it looks like shadows are turned on and all of the lights are iintersecting, but, yet again, we have no file…

3 light sources is not 3 point lighting.
Think of it this way:
1-You want to establish a MAIN LIGHT SOURCE (or KEY LIGHT) to help describe the object. The shadows projected by that light will help the brain determine if the object is flat or round or understand 3D from a bidimensional representation. This light usually comes from the sun (we only have one in this solar system) or a window. This is the light that determines the brightness of a scene. The size of the lamp will determine the sharpness of the shadow. A point light will give a sharper shadow than a hemi light or an Area light.
2- You need some kind of FILL LIGHT so the shadows are not completely black. In real life fill light comes from the light reflected on the room or the atmosphere, and is for the most part very soft, causing no shadows or shadows that are not as deep as the main light source’s. To do that in blender you can use area lights thate much larger than your object, but also less intense than the Key light. Remember this are just meant to control the contrast of the image and let you see detail in the shadows. Try to keep that light close to the camera to minimize the number of visible shadows or turn off the shadows for that particular light (good in theory but no very realistic…)
3- BACK or RIM LIGHT. to keep the object somehow separate from the background or to further reveal shapes that might get lost in the main light. Most things in real life don’t have a back light. We’re used to it because of hollywood films where the actors carry a glow no matter where they go. It’s used more for pictorial effects and you might wan to consider it’s use carefully.

Three point lighting is just a very simplified departure point for lighting. You don’t always have to have three lights, sometimes one will do or you might need a multitude of sources depending on what you’re after.
If you want to learn more, get some books on the history of painting. Lighting has been studied for thousands of years, and the quest is far from over…

Thanks for the replies, guys!

Atom
…So pick one light to be your shadow caster and turn off shadow casting for the other two…

That worked! But now I have a dark region receiving no light:(.


BTW, I was following a tutorial on 3-point lighting on blendernerd and kept ray shadow on for all lamps as shown in the video. So, what was the problem?:confused:

cegaton
…If you want to learn more, get some books on the history of painting.

Can you list some good ones?

Here’s the file if anybody wants it.
Vase.blend (475 KB)

That worked! But now I have a dark region receiving no light:(.
That’s because there is no lamp shining light on that part of your object

Lamps energy increased to exagerate the lighting



There are no lamps on the camera side of the object, only from the back and two sides

okay…I added one more light and that solved the problem.

So I can add any number of sources even if it is called 3 point system. Am I right?

You can add as many lights as you wish given your current lights are not positioned in the setup for a traditional ‘3 point’ light system. You would usually at least light the part of the object seen by the camera