Shadow issues

Been using Blender for about a year now. In that time, every so often I’ll render a scene and there is no shadow. NONE. Theres a spotlight, all the necessary buttons are turned on, but nothing. I’ve ignored it in the past but its getting a little annoying.

What can I do?

Here is an example of a christmas scene I’m making:
http://redbyte.creativeblend.net/images/noshadow.jpg
As you can see. No shadow.

Here is the .blend file if you think you know whats wrong:
http://redbyte.creativeblend.net/other/noshadow.zip

Thanks in advance.

Click on the lamp and turn on Ray Shadow on the shadow and spot panel.

You have two choices when this happens.

  1. change the clip start – a value of 4 works well for your scene.

  2. set the bias value close to the minimum. ie. 0.020 which works for your scene as well (leaving the clipstart at 0.1)

GreyBeard

If you do what grafix said, you’ll also have to enable “Ray” in the Render Settings.

But if you still want to use Buffer Shadows, just decrease the Bias parameter. An explanation of it can be found in the manual. Or what GreyBeard said; you want to have the ClipStart and ClipEnd settings contain your scene but not go too far out.

Sweet. It worked great. Thanks everyone.

What does Bias do btw?

the shadow buffer technique only has so much precision

if your clip start and end aren’t close enough together you may see artifacts, the bias value can be used to tweak this.