Shadow problem + Yafray problem

Hi all.

I have a problem. I’ve been testing with UV maps, alpha maps and all and now I have a problem. See the image below to see what I mean:
http://img80.imageshack.us/img80/6905/shadow3sr.gif
I want the alpha-UV-mapped image to cast the shadow as it should, don’t know how I should say it. You probebly know what I mean.

Is it possible to make a more accurate shadow?

the shader of the mesh under the leaves has to be set to “TraShadow”, so it can receive transperent shadows

Thanks mate. That’s about it :P.
http://img153.imageshack.us/img153/2006/yes7ub.jpg
If the scene finishes, I’l show it here.

Here is another problem I had. A scene rendered with Yafay.
http://img476.imageshack.us/img476/4089/57min2gm.jpg
Anybody know how I can get rid of these dots/spots/stains?

I never use yafray, but previous questions like this usually mean you don’t use enough photons or the GI quality is too low, you could also try an unbiased renderer like Indigo but making GI based on true light physics is slow as i’ve heard.

Thanks. Now I’l stick to “biased-rendering with photons” if that’s correct. I had a “Best” quality setting in the previous render, but had perhaps too little photons (or better said, too many lamps; Yafray seems to devide the number of photons over the present lamps) and have decreased the # of lamps and increased the # of photons now. Here is the result. Much better I think. It’s rendered in 45 min.
http://img469.imageshack.us/img469/4633/45min8iy.jpg
Next to the mirror and cd-rack (in the middle) I see some weird spots. I guess this is caused by too little photons, so I’l increase it once more.

Looks a lot better now.

What are your settings now?

Auto AA
Clamp RGB
AA Passes
AA Samples
Psz
Thr
Raydepth
Bi
Gamma
Exp

Method
Quality
Cache
No Bump
Shadow Qu.
Prec
Refinement
EmitPwr
GI Pwr
Depth
C Depth
Photons
Count
Radius
Mix Count

Auto AA - On
Clamp RGB - On
AA Passes - X
AA Samples - X
Psz - X
Thr - X
Raydepth - 7
Bi - 0.001
Gamma - 2.2
Exp - 5
Method - Full
Quality - Best
Cache - On
No Bump - Off
Shadow Qu. - 0.9
Prec - 9
Refinement - 1
EmitPwr - 2
GI Pwr - 1
Depth - 5
C Depth - 1
Photons - On
Count - 300.000
Radius - 1
Mix Count - 120

I have two square area lamps (one in the window and one from behind) bothgamma of 1 and both a bit yellowish, the one in the window with energy: 1, distance 40 (the line doesn’t reach to the end of the scene, should it?), samples 16. The other area lamp had 1 sample and has 0.4 energy and also 40 distance.

Here is the new render with these settings. If anybody know how to improve the render with different settings, please say so.
http://img133.imageshack.us/img133/8845/40min6gc.jpg
Render time 39 minutes.

Samples don’t matter because when Photons are used, arealights become pure photon emitters

Be sure that your photon sources power is = 1 (arealight, etc)

Control light intensity of all emiting objects always with the EmitPwr slider.

Try with lower radius untill noise starts being noticeable. You will gain a bit sharpness and detail with that.

Then, If your computer can cope, use higher photons count, for instance 500.000 and increase mixcount (max 150).

Then, increase radius step by step untill the noise disappears. Decrease mixcount as well if there are problems of over-averaging. Decrease photons count if you don’t loose render quality, to reduce render time.

Finally, Use refinement of shadows= 0.05

Thanks a very lot Alvaro. I’l try that for certain. I’ve modified some settings just now and am currently rendering. I’l post the render when it’s finished.

Here is the render. Again a bit better, but still not quite good.
http://img157.imageshack.us/img157/6664/30min6tz.jpg
Rendertime: 30min.

I’ve changed some settings to this:
Photons 400.000
MixCount 135
Refinement 0.05

Radius is 1 and I’l lower it for the next render. Anyone know what a good MixCount and Radius is for this image? If you see the result, do you know how to improve it? Lower or increase the MixCount and/or Radius?

Thanks for the help so far.

Btw, how do you like my chair? :smiley:

well, from the image I can’t tell you what’s wrong. I think it is radius.

can you show a render with standard Photon settings 100.000/1/100?
then can you show another render with the scene scaled down 1/5, but with the same settings? without furniture if you wish, and lower res.

BTW, are those walls solids? If not, just try the same render but give your walls some thick

PD: this is a document to understand a bit photon map leaks, and explaind why single-faced walls produce leaks:
hXXp://wscg.zcu.cz/WSCG2006/Papers_2006/Full/E73-full.pdf

Alvaro.

I really appreciate your help Alvaro! I am changing the settings now and will show the render in a min.
-edit-
Here is the first render. The scene has less poly’s and some models are hidden for faster render times.
Render settings: Full - Best - 100.000 photons - Radius 1 - MixCount 100.
http://img82.imageshack.us/img82/762/119gh.jpg
Render time: 30 min.

The render with the scene scaled down (though the scene above was already scaled down quite a bit) will be posted in about 30 min :P.

Here is the render with decreased size of the scene.
http://img160.imageshack.us/img160/5899/120ix.jpg
Render time: also 30 min.

And here is the same as above (all settings and stuff the same) but the number of photons is increased to 500.000 (so 5x as much).
http://img60.imageshack.us/img60/2641/133gd1.jpg
Render time: 40 min.

Interesting tread. Why do you think that scaling the scene down makes a difference? I thought that everything is on a relative scale in Blender.

I thought so too, but I was told to do so by Alvaro :D. I hope he takes a look here soon. Perhaps he has a next step for me to take…

I tried some other settings. The result isn’t much better if not worse.
http://img58.imageshack.us/img58/3016/141tz.jpg
Render time: 40 min.

Settings: Count 300.000 - Radius 4 - MixCount 1000 - ShadQu 0.9 - Prec 12 - Ref 0.04 - EmitPwr 2 - GI Pwr - 1

I can’t figure out how to improve the render :(.

Try this…

You don’t get much noticable qualilty improvement by setting quality to “best”. Try using “high” for now.

Pump photons up much higher. Don’t be afraid to go as high as
1 000 000, or even past. I’m pretty sure the problem is with your photon count since I have had the same problems before. Increasing the photons solved my problem.

Very nice renders BTW. :slight_smile:

Thanks a lot Dbugged! I’l try that. I’m currently rendering with 800.000 photons and improved Prec (7). I hope the result will be good. The render was done with best quality settings but I’l try high next time.

Do you know if the difference is a lot between Best and High? And if the render speed will be increased by it? I’l try anyway and probebly make my own conclusion. Thanks mate!

It is strange. The default settings should work better if GI quality is best. Scaling the scene down has removed quite noise. Radius is scale dependant, and it doesn’t work well with big scenes. I hope you didn’t use centimeters as work units for that scene. Also be sure that the arelight is not behind that venetian curtain.

I woud try your scene but with a relatively small radius, between 0.5 and 0.1. That will increase render times a lot.

I’m not a big fan of high photon counts, I usually get good results in the 100.000 - 500.000 range. Besides, beyond 600.000 my computer usually can cope, but if you can, try what Dbugged suggest.

Can you post the scene only, without furniture?

BTW, had your scene solids walls or they were single face?

I’ve changed them into solid walls. It wasn’t like that. (It’s changed after your post where you mentioned it.)

I’m going on vacation tomorrow-morning (ehm in 8 hours :P) and don’t have time to change things in the meantime. I’ve put my .blend file on my GooglePages here. Please don’t use anything in the scene for any purposes but educational ones.

Alvaro, if you can find the time somewhere in the next week to try some settings, I’d be very pleased. If you can’t find the time or don’t wish to put more time into this, no problem, though I hope you, or anyone else who is trying to help, will do magic with it :).