shadow question

I have two objects in my scene, one glass, other solid. Both need to cast shadow. However, the solid objects shadow is too black for the scene. Hitting a white floor should make it more subtle and greyish when mixed with a white floor. How can I change the blackness of the shadow? I used just one area light.
I had a cap on a transparent bottle, the bottle had a nice shadow but the cap sitting 30cm above floor level gave a pitch black shadow. In reality a shadow like that would almost not be visible because of the distance to the floor. Is there somewhere you can turn casting shadow off for a particular object if you can’t adjust the grey factor?


Increase ‘Samples’ in ‘Shadow and Spot’ panel, and increase ‘Size’ in ‘Lamp’ panel?

Increased samples (16), size to max see attached result. Darkness of the solid shadow is still black.


Try adding Ambient Occlusion.

Did you try it with more distance between the ball and plane?
If the cap is a separate object you could have it lit exclusively by a lamp that casts no shadow. Try looking in the Wiki -

As for my problem with the cap, I think moving it to a different layer with it’s own light does do the trick (must say, tried it before to no avail). But my scene is more simplified and as you can see I am able to set shadow off by moving it to a different layer by also copying the light. I also tried ambient occlusion (I am not an expert on ambient occlusion), tried a couple of settings. Shadow kept on being too dark so it looked it didn’t influence it, will have another look at the tutorial though. A subtle grey shadow is hard to achieve, tried to do the trick with a spotlight (cast shadow only) and reducing the energy levels. Problem with this is the shadow of the transparent object is almost gone and the shadow of the solid looks subtle grey. So both objects need their own layers/floor and lighting settings to make it work.


And what makes you say that the shadow below the solid object should not be black as in your picture when the lamp is position straight above? Maybe your setup of the lamp is the problem and not the shadow itself.
Remember shadows are not an entity of itself rather they are the lack of light. So if you want your shadow to be less dark add a Hemi to lighten it up but remember the hemi will also affect the other objects unless you use a lamp group to exclusivly light the plane or you use a layer approach where the plane and hemi is on the same layer and the hemi only affects the layer.

Another thing you should know in case you didn’t (I didn’t in the beginning) A lamp can be on more then one layer at the same time. Simply hold the Shift Key while you are in the layer dialog. (M key).

EDITED: Color bleeding does not work unless you use Radiosity in Blender Internal Renderer.

I would say, an area light is similar to fluorescent light and give a broad beam of light to the object and surroundings. The light hits the object, but also hits the white floor and walls, bouncing back to the sphere lighting up the shadow. So you would think the shadow shouldn’t be dark but grey because of all the bouncing rays. I can try to add a soft back light to see if I can light up the shadow as an option and hoping the shadow of my transparent object does not disappear.
I also noticed I can only have shadows in layers if I also move my background to that layer where the objects having their own lighting setup. This brightens up my floor to much. So it is getting a bit overcomplicated to get a desired result through moving it to layers and setting lights.

In Blender’s Internal render engine, light rays do not bonce off objects. Once they hit an object they are done. That is unless you use radiosity (which does calculate bounced light), you will need to add other light sources or AO.

What you want is an unbiased renderer that does all the light calculations for you. Take a look at indigo or luxrender (the later being still in a prerelease phase)

I used yafray and loaded yaf(a)ray to improve the quality of the rendering (glass, PET). The downside of it was, some settings work and some settings don’t work in blender. The light settings are totally different, with yafray (no transparent shadows), pretty critical for the products I like to render. In yaf(a)ray, after a day of changing lights and settings the result were pretty poor so I gave up on external renderers at this stage. I couldn’t find any good tutorials on yaf(a)ray so that made it more complicated. Must say, just started Blender two months ago and I am back to the Blender internal renderer. I will keep Indigo in the back of my mind though because that is the next one I want to give a go.