Shadowing problems, when using a plane behind a sun.

Hello BlenderArtists,

I’m a newbie at Blender. But I really love its possibilities and great power.

For training I’m trying to model a scene showing a patio at sunset. I use a plane with a self-made picture as background.
Between the patio and this plane I placed the “sun”-lamp. Unfortunately the shadowing/ lighting doesn’t work in the way it should.

If I deactivate “traceable” on the plane-object the shadowing works correct, but I cannot see the water through my glass pane because the ray-tracing is disabled.
When activating “traceable” I can see the water but the shadowing is wrong.

What do I have to do, to render this scene correct?

Thanks in advance :)!

You need to give more info, screenshots, link to blend file.
‘Shadowing is wrong’ what does this mean ?
Note that transparent objects cast shadows just as if they are solid. Any materials that will receive these shadows you need to set ‘Receive Transparent’ in their Material / Shadow settings

I’m irritated, screenshots should have been attached. I’m trying again.

Attachments



  1. Sun type lamps generate their ‘light’ from outside the render. So even though you have the lamp PLACED between them Blender will still consider the light as coming from behind your image plane no matter what.

  2. Uncheck “Cast Shadows” on the image plane

Thank you for your answer, Star Ranger4. I guessed as much that the light is coming from behind the plane.
I deactivated all cast shadows checkboxes but the render output is still as in my former post (“traceable.png”)

I attached a screenshot of my material settings.

Thanks again for your help :).

Attachments


You need to uncheck traceable on the background plane and check traceable and receive transparent on everything else.

@Tech Wreck thank you for your answer.

I tried to implement the tips I received in this thread, but unfortunately I’m not able to reach my desired result. My results switch between the two screenshots I posted earlier. Hence I attached my blend file in the hope that this will simplify to help me :).
In order to upload the file I had to remove the texture image files.

Thank you all for your help :)!

Attachments

teapotScene-BA.blend (1.41 MB)

Thats not going to help much… Repack those textures so we can see em (might be summat in the textures) and either zip it to get it under the 15m attachment limit or stick it someplace where you can link to the download

When I try it without textures, the same effects happen but I can understand your argument hence I’m going to share it with textures.

Because I’m not able to upload it direct to this website, I’m going to share a link from sendspace.
Here you go: http://www.sendspace.com/file/b10yjd

Thank you all again for helping me :).